Adrenalin 22.5.2 - 22.7.1 & HP reverb G2 Problems - 22.8.1 brings the fix

Did a 30min flight from nuernberg to hof, all went well - BUT…

after i closed Windows Mixed Reality and re-opened it the flickering was back, so it is NOT FIXED!

i registrated the issue by seeing random single black frames in the right eye, same behavior was with 22.5.2, so now again have to remove this … and going back to the well working 22.5.1. :roll_eyes:

It’s a nightmare these days with both, MSFS & AMD.

The same here with flickering and black screens with the 22.5.2 driver. There is one thing I am curious about if other G2 users have this: MSFS always quits with a amdxc64.dll error when I have used the G2.

1 Like

Lucky you that it’s working. I tried 22.6.1 today and had the same problem as 22.5.2… so back to 22.5.1 for me. I sent another bug report to AMD over the issue.

I’ve been busy at work and only flew a 40 minute flight with the FBW320. Will have more time over the weekend.

I have been using 22.6.1 since release and have not seen any issues with my Reverb G2.
There is none of the flickering I saw in the 22.5.2.
When Installing new drivers ensure all driver Cache libs are cleared.
There is an option in the AMD Graphics setting to reset the Shader Cache.
Clear the C:\Users\xxx\AppData\Local\AMD files.

I’ve done all, with DDU, without, as Administrator, did use the reset button you mention. It works the very first start and after the second run of WMR powered dark grey displays or flickering.

Do you have an AMD chipset? if so, x570?

Hi, I have older Intel z390 motherboard.
Only other option I would is to terminate / repair /reset Mixed Reality Portal App.

the only thing that needs “repair” is the new driver since 22.5.2 which makes problems on full AMD systems. It looks like they are not able to bring drivers for their own plattform.
22.5.1 runs perfect stable with WMR and the G2, i won’t know what repair i should do. :roll_eyes:

several posts on reddit and on the Amd forum itself, i don’t think they all have broken mixed reality portals!

I just wanted you to know… I just upgraded from a rift s to a reverb 2 v2 yesterday. I have a 6900 xt GPU, 5900x cpu and a rog x570 motherboard. I racked my brain yesterday trying to get the g2 up and running without the flickering. I thought HP had sent me a bad unit. After many hours of checking EVERYTHING it could be, I ran across this post. I rolled my driver back to 22.5.1 from 22.6.1 and I be darn if that was the problem. Thanks again. It is now running great. I really wish AMD would fix this driver problem…

Great to hear that it also works for you!

When you had the bad driver installed were you getting fast flickering constantly or intermittently?

I usually fly around 45 minute flights lately and with
22.6.1 installed I haven’t had a problem.

AMD Ryzen 7 3700X 8 Cores
ASUS Prime X570 Pro
32GB 3200 MHZ
AMD Radeon RT5700XT - (Driver 22.6.1)
FF PS 1050w
Windows 11

MB and GPU set to defaults

The very first connection with the reverb g2 was a powered dark grey screen, powered off the googles and powered on again and there WMR worked.
Did a flitght for 30min then, where i recognized the random black pictures in the right display, which i also had with the 22.5.2, powered everything off. The next start oif the headset the flickering was back.

But i am on win 10, maybe thats the difference.

What I found works best for my setup - 5950x + 6900xt + 32GB Ram + Quest 2 - is not installing adrenaline at all. In device manager the driver is version 30.0.13023.4001, which Windows automatically installs. According to MSI afterburner it is adrenaline

If I install any version of Adrenaline the grid background in the Quest Link home screen moves around constantly. It’s been doing that for a long time now, so I stopped using Adrenaline and I use MSI afterburner to change the Performance settings instead.

AMD just released 22.7.1

So did it fix the flickering and Blackscreen Bug for you guys?

This is in the “Known Issues” section for this driver release:

“Virtual Reality headsets may flicker with some AMD Graphics Products such as the Radeon™ RX 6800 XT Graphics.”

Just tested it and yes, it still flickers like crazy.
Oh well, these uninstalls are killing me.

Testing today with 22.7.1 I am not seeing the flickering I saw before.
DDU Cleanup before Admin Install 22.7.1 plus clear all AMD and FS2020 Cache folders, will report back if flickering re introduces its over the next couple of days.
FS2020 is also a reinstall of SU9 after a couple of days testing SU10 Beta
In DX12 I am seeing a Tracking Juddering when using FSR through Toolkit.

I did it that way with 22.5.2, 22.6.1 and 22.7.1, it only worked for the very first use.
I hope for you that it works for you, but it doesn’t for me :frowning:

Still seeing flickering with 22.7.1. Will try a full cleanup/reinstall and report back.

Day 2 Flickering is back, uninstalled 22.7.1, trying something different today, only updating the 6900XT driver in Device Manager not install full AMD Adrenalin suit. see if that makes any difference, not flickering during first run but lets wait and see over next couple of days.