Adrenalin 22.5.2 - 22.7.1 & HP reverb G2 Problems - 22.8.1 brings the fix

I was happy to read that AMD have officially released the DX11 performance driver now with the 22.5.2 Adrenalin.

Well, my happyness was kinda short, this driver seems not to be compatible with the HP reverb G2.
At first it was flickering like crazy, on the next try the screens were powered but WMR didn’t start in the googles. Tried different USB ports. When it decided to work, then the flickering was there. Uninstalled and re-installed 22.5.1 whql and all works again.

Anyone else experienced the same?

64gb ddr 3600
HP reverb G2


I have the flickering in the quest 2 with this driver on the oculus home screen (almost makes one sick) but once I enter the cockpit and hit CRLT + NUM2 all is smooth as butter.

6900xt SE edition stock
32 gigs
Quest 2 V40 app - v39 headset

Seemed a bit funny as it loaded the first time but since then it has been good.
10700k,6800,32gb,Reverb G2

So far so good for me.

Win 11, AMD 22.5.2, Reverb G2

Yes, I’m having major problems too. I have the flickering you mention, and also if I open a desktop window in the WMR Portal then all of the colors are washed out. The colors in the rest of the environment are normal except in the desktop window. The flickering happens in the sim also. It doesn’t go away.

While troubleshooting, I found that if I switch the refresh rate from 90 Hz to 60 Hz then the flickering is worse. Switching back to 90 Hz sometimes the flickering goes away but will come back after a time. If I change the headset resolution I will get a black screen unless I have it on the 4K recommended setting. Note that the washed out desktop window colors remain no matter which setting I adjust.

I’m reinstalling the 22.5.1 driver.

System: 6900xt, 5800x, Reverb G2, Windows 10, all software is updated

Same here with my G2 on a 6700XT. Drove me mad for a while. Trying different USB and Display ports, reinstalling all WMR components then got stuck with the “please put on your headset message” until I realised that I could press Win-Y to get past that and then I finally downgraded to 22.5.1.
Really thought my G2 was toast.

Same for me with 6900xt and a Reverb G1. They seem to have added a blank frame between each correct one causing a massive flicker. Rolled back and that corrected it. 22.5.2 is hot garbage.

Same problem for me 6900XT Reverb G2, first noticed in May Preview Driver switching to 60hz sometimes worked, rolled back to 22.5.1 cleared the issue.

Bro I could kiss you dude no homo. I have been struggling for DAYS trying to figure out why my G2 has been flickering and giving me blackscreens. It would eventually get worse with the blackscreens to the point of today not being able to reset anything despite restarting the software/restarting computer/power cycling headset/ changing all kinds of settings etc. I have a 6950XT and 5900X and I thought my G2 was broken despite taking excellent care of it. Rolling back to the previous driver ( 22.5.2 to 22.5.1) fixed everything. I cant thank you enough!!!

1 Like

hehe, no problem :slight_smile:

Did you try the 22.5.2 beta or the 22.5.2 whql? The whql driver was released yesterday, may 31.
I had the flickering with the beta, but i deny to test the 22.5.2 again as i think the whql logo is just cosmetic :roll_eyes:

Yes! You saved me from throwing my G2 away.
Had the same problem, and reverting to the older version of the driver worked for me too.
Thanks a lot for sharing it here!

I get the same flickering with the “whql” driver. I rolled back to 22.5.1 again.

I hope everyone is submitting a bug report to AMD to get this fixed. :+1:


I dunno about you guys, but I went back to 22.3.1. These latest drivers are JUNK on my machine. I’m getting a terrible taste in my mouth from AMD and Adrenalin. They are NOT helping us with MSFS in the least!

1 Like

AMD did re-release the 22.5.2 yesterday (June 20) again, i just re-tested this one now, i didn’t experience the crazy flickering again with the reverb G2. Performance was around 46fps. Only some random short abnormalities were registrated in the right eye, but i cannot for sure say it is the bug.
Will test again on a flight i already know.


Nope, after 2nd try and with old directx cache files deleted it’s flickering again.
Back to 22.5.1


I’ve been on 22.5.1 for a while with no problems, but then two days ago for no reason my G2 just went nuts. I had resisted installing 22.5.2 because of problems people were having, but why the earlier driver would suddenly cause problems, like crazy 20fps-ish flickering and random black screens has me stumped. I thought my version 1 cable had given up the ghost, so tried to order the new version…out of stock everywhere. Tried WMR reinstall, nope, nothing worked.

So I left it for a day or two and then thought maybe a driver windback could help. I checked here first and sure enough, I also went back to 22.3.1 like CapnCarl 4445 and everything now works OK.

32GB 3200 RAM
Win 10 DX11

1 Like

I bet Windows automatically updated your gpu driver and then it started to get crazy.
I had that already with v21.12.1 and Windows decided to install another driver and then the AMD software did not work anymore.

22.5.1 is definately ok, tested it 3x now :+1:

1 Like

Now that’s an interesting thought, as I had a Windoze update a day or so before this happened, during a short break from flying in MSFS. However, my Adrenalin software still showed me as being on 22.5.1. Maybe that update still managed to screw things up somehow. I’ll try going back to 22.5.1 tomorrow (it’s late here in Oz) and see what happens. Many thanks for that possibility.

1 Like

AMD have released Adrenalin 22.6.1 Optional (WHQL) after mulitple versions
of 22.5.2, be interested in peoples viewpoint. Have issues with HP Reverb G2 of flickering been addressed and resolved.

Just installed and testing it right now. in 30min i know more :wink:

I had problems with VR using 22.5.2 and went back to 22.5.1 also. I installed 22.6.1 today (cleanly removed 22.5.1 first using DDU). In my case during the install it went to a blank screen towards the end of the install. I had to do a hard reset of my pc and all went to normal and indicated 22.6.1. Could have been a quirk in my system.

I just completed a 40 min trip to KLGA (NYC) and all went well. Didn’t notice any obvious increase or decrease in performance so far…