After a group flight "Flight conditions" not accessible, stuck in an old group?

Same Problem here. Maybe we can help each other and be „friends“ to leave the group? :thinking:

1 Like

Same problem here. I’ll try your way and tell here later

Dude, this doesn’t work for me. Do you know if I make another profile my Xbox ultimate will usable in the new profile?

Hi there. I’ve got the same problem here. Did you find the resolution for this problem?

I believe so as long as the console is set as your home Xbox. Did you definitely turn off ALL online settings and fully close and restart the game before turning them back on again?

I did all the way you described. The good thing is the game did not crash after that. But the climate and date remain freeze in the date I flight with my friend.

Sorry man, I had the problem for a few weeks and this is what worked for me. Really needs a patch by now.

1 Like

I had this issue and FINALLY figured out something that worked for me. It definitely seems this is tied to our Microsoft gamer accounts. I just simply logged out of my account in-game by clicking on my icon in the corner. I waited until the game asked me to log-in again and I picked an alternate account. It was there that I realized everything worked as usual…so I logged out of the alternate account and back into my normal account. And it fixed all my issues linked to my normal account! I will say that my controls needed to be set back to the profile that I created previously (so make sure control bindings are backed up). Also, some of my settings seemed to be reset such as the multiplayer/online settings. So, check to make sure your settings are back to the way you want them. I’m not sure if logging into an alternate account is needed. It might just simply be to log out and back in again. I can finally change my weather mid-flight! Its been months since I’ve been able to do that! Whew.

OH! Also, my ATR setting was greyed out during flight after this fix. So I did the ATR fix that has been posted online of changing the assistance options to “All Assists”/Apply and Save/ then Back to “True To Life”/Apply and Save. And this fixed that issue.

I hope this helps someone out there!