After a group flight "Flight conditions" not accessible, stuck in an old group?

Hi everybody,

I joined a privat group flight recently and after that I closed MSFS2020 After the next restart I am not able to get access to “Flight Conditions” at the world menue. I have all the time real weather and time, when loading a flight, there no access to the weather or daytime.

It seems, I am still stuck to this former private group, but I that is closed for days. There a no group flights showing up, I could leave. All other online services within MSFS2020 are working well.

Any ideas what to do?


Zendesk had no solution yet under ticket number 100061

You can open the Friend Icon on the top right corner next to your profile, and choose to Leave Group.

Sorry no, there is nothing showing up to leave a group, just showing up my friends

Make sure you don’t have your multiplayer setting at “Live”, that setting locks you into Real Weather and time on the world map, and removes the weather and time tab from the tooltips when flying.

I prefer to have multiplayer set to Live myself, so I don’t get tempted to change the weather and time. Lol.

Sorry, I don’t have access to that menu; that is the problem. “Flight conditions” are greyed out

Did you ever figure this one out? I’m having exactly the same problem now and it’s driving me crazy. Stuck in a multiplayer group and can’t change the time of day or the weather.

1 Like

I have the exact same problem as well. Eager to know if anyone has solved it.

This worked for me. Had exactly the same issue as you’ve got. Only difference I done was got someone to invite me to a multiplayer game and it then allowed me to leave.

Thanks for the fix.
I have the same issue on Xbox Series X.
I will try to get invited by a friend…

@D1rtyDuckUK - this workaround works fine! Thank you so much. :+1:

1 Like

Hi guys, I did find a fix for this issue that’s plagued me for a few weeks. If this happens and you get stuck in a group that you can’t leave (can’t open group window), the following worked for me; keep in mind this is if the original solution above does not work and your original group leader is not available:

  1. Start a flight, get airborne (I think this is quite important).

  2. Go into options and turn off all online settings in the data menu. Apply and save.

  3. The game will now load for a while, and for me it caused a CTD.

  4. Reload the game, go into options and turn on all online settings again in the data menu. Apply and save.

  5. The group window should now be accessible.

I think causing the game to CTD may be quite important to the process, potentially wiping your online blueprint from Asobos servers. This is why getting airborne so scenery is being utilised may be important. If you just change these settings off and on while in the main menus, without being in a flight, it definitely doesn’t work.

If this works feel free to paste this solution into other threads.

Good luck!

Still having this issue and dont have anyone to add me so I can leave Old group

This is still an issue.

So have anyone found a solution? I’m stuck back at September 30th at around noon. Time and date always revert back after a few seconds.

The old group leader invites me again, than I was able to leave the group. That was my solution.

The reply above is correct.

I had this very same problem, I shall provide how it happened to me and how you can fix the issue.

  1. I started a group flight
  2. I invited my friend and started the game
  3. I left the game and group before my friend
  4. To fix, your friend must make a group flight and invite you
  5. Then, you must quit to main menu and choose to leave group
  6. Now your game will be FIXED!

If your friend started the first group flight, then go through this list the same but vice versa.

1 Like

problem I am having is the only friend I had who caused this issue has since uninstalled, I am struck in limbo.

This can be done with anyone online. It doesn’t have to be done with the same friend. Sorry if I didn’t make that clear.

I only had one friend who played lol, I have been stuck with grayed out flight options for about three months now, ‘Group Only, Clear Skies at 3am and AI traffic’ everytime I try and change it it just flips back :stuck_out_tongue: every flight has been at night