After SU10, FPS still drops during flights

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

Have you disabled/removed all your mods and addons?

Brief description of the issue:

Sim Update X, issue is still not fixed. Just after dozens of minutes FPS will drop as always.

In SU X release notes, there’s “Improvement” on this issue, in reality nothing has been improved.

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

PC specs and/or peripheral set up if relevant:

Build Version # when you first started experiencing this issue:

:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:



Don’t even want to try a 2 hours flight with the 737-800…

What’s weird is I only had this issue with this aircraft, was able to make a 3 hours flight with the Fenix with no issues.

Maybe new Nvidia drivers with DX12 will help.

1 Like

FWIW, are you still using the same graphics and flight parameters (no changes) for over a year? I’ve had to change many of my graphic parameters going from SU9 to SU10 to get any performance improvements.

Became most prevalent for me after SU9, where the time before this happened was ~5h (so no transatlantic, thanks for the B748…) it’s now very consistently 2-2.5h.

Same just a few moments ago - as 2h in-sim ticked through, GPU plummeted back to idle and down to single-digit (i.e. unusable) FPS. Other values normal - CPU max ~70% and RAM consistent etc, just as though MSFS is like “paaaah CBA using the graphics card any more”.

And as above still no fix. Diabolical.

But hey, “Game of the Year”, right?


LOL that was last year. ;p

1 Like

this is very strange… for me it’s better with the SU10 with my GTX 1080 (before at Los Angeles or New York = 8 FPS, and now i have 25 - 30 in the same place with the same setting Ultra, PG ON with all world update in 1080p (just the LOD of terrain has 200 and not 400), and i have flight more than 2 hours and no drop too now, you have Pushback Toolbar and you have update all World Update ? i know when i have delete for me pushback toolbar the problem with fps drop during long period played has disaper

1 Like

No issues now with SU10.

I still continue with FPS drop during flights.

Yesterday i start at LPPR with 35 fps, and arrive al LSZH with 20 fps. I notice FPS drop when start descend.

I use a RTX2070 Super.

And i dont know why, but for me, using 2K or 4K, i have exactly the same FPS’s.


:smiling_face_with_tear: Ah of course, my bad

To be fair, the issue was since before I had Pushback Toolbar, and I had tried with empty community folder and it was still doing it after 4h or so. BUT, I haven’t recently - I’ll try a flight >2h without PBTB and see how it goes, thank you!

1 Like

Generally, the GPU sends about 4x more bits to a 4k monitor than to a 2k monitor if my math is correct. In other words, FPS should be higher using 2k vs 4k. But in your case, it is not. Your 2k should be higher. This means your GPU is waiting for the CPU to send it more 2k frames to process. But the CPU cannot send 2k frames fast enough. To send more 2k frames, the graphic parameters have to be adjusted to move processing from the CPU to the GPU usually by setting the LODs lower.

1 Like

For me the FPS drops are 100% related to traffic. Turn all traffic off (including airport traffic and fauna) and no FPS drop at all. Leave it on and slowly the manipulators increase until it grinds the cpu to a halt.


Any update from Asobo on this considering they started a fix a few months back?


tell me a feedback, i think try to reinstall the pushback toolbar now that the SU10 solve all my problem for know if the issue of that is the mod or just the previous SU9, for the moment i have flight 9 hours since the SU10 in total and it’s all good and same with complex aicraft as PMDG 737 or Concorde

Ah and for info i have upgrade my PC yesterday i have passed of 16 GB of RAM at 32 and the little stutter has disappear now, Orishek you you have 16 or 32 ? I know you have this problem too

I am of the opinion that people were incorrectly blaming toolbar pushback for these performance drops. But if you want to be safe you can leave it installed, then once you have used it. Use the cog to disable it from the toolbar and it won’t be active anyway. Then when you need it, just enable it again.


yeah you have maybe reason, this is for that i want test again now for know the real cause of the issue

Is anyone else still getting this issue?

I had it just now. 3 x flights this week, no change to any configuration or graphics setting.

2 x flights of 4 hours - no issues (daytime).
1 x flight of 2.5 hours - no issues (night).
1 x flight of 2.5 hours (return leg of above) - issues (daytime) - see below.

The performance drop was massive, my GPU util dropped like a stone.

Now the fun thing is, if I paused the sim and went into the main menu, my GPU util doubles and no issues, then unpause back into the sim, the 13fps etc and GPU util drops down again and performance is terrible.

I reduced LOD, played around with settings, made zero difference to fps.

Now when I landed, I shutdown the aircraft (11fps), exit to menu, no restart, straight back in at same airport same gate, butter smooth, high fps, high GPU util.

What is going on?

AMD R9 5950X // 64GB RAM // NVMe // ASUS ROG STRIX 3090 OC

If anyone has the same system as me and does NOT experience this issue, please could you share your graphics settings so I can try them?


Task Manager shows the overall “big picture” which is helpful here. The developers FPS counter can be misleading at times because it only shows the “small picture” of the graphics pipeline.

Look at the GPU and Network in Task Manager. Notice how GPU utilization drops off as network activity goes much higher. Something is happening with the network possibly downloading graphics info needed by the GPU. Looking at the Developers FPS, the Manipulators are the bottleneck for whatever they are processing causing FPS to crater. CPU processing isn’t changing because the manipulators don’t seem to be able to process any faster.

Generally when pausing or going to a menu screen, the system has time to finishing processing whatever was in the pipeline returning FPS to “normal”. I don’t know if this is exactly your problem because I don’t know what the manipulators are doing here.

There are probably some graphic parameters that could be changed that might help or hurt. Basically, the manipulators need to do less work.

Often airliner cockpits have demanding graphic requirements. FWIW try flying the same flight in a less complex stock aircraft like the C152 or C172 and see if there are any differences in Task Manager and the developer’s FPS counter.


Thanks for your detailed reply, that is an excellent post. I really appreciate it as its narrowed it down.

One thing I didn’t mention, I am still on Windows 10, having done a quick search on “manipulators” came up with some people upgrading to Windows 11 and that seems to have fixed it for them.

I’m not sure if that would work for me, since it seems to be a download issue midflight from the internet.

The interesting thing is I have played MSFS from release and originally had a 500GB rolling cache, I never had this issue.

I’m tempted to try turning it back on.

If anyone wouldn’t mind sharing their graphics settings with a spec system similar to mine, that would be a great help. Admittedly mine are almost on max (DX11, TAA) I have not tried DX12 / DLSS yet.

I fully agree with this symptoms, after a long flight, drop of fps.
Even if I exit flight, drop is there.
Specially happens if I do a long flight accelerating time to 8x etc.
If I pause the game, it normally goes back near to normal fps over time waiting maybe 30 minutes. Not as fast as just rebooted, maybe 5 or 8 fps less, but better than when it’s overloaded.
If I close the game and reboot game, it’s back to full fps great performance (i9 10900x - rtx3900).

I see same thing as you guys in Task manager. GPU usage drop, one core up, lots of threads pending.

Could it be possible that there is some kind of Quality of Service on data consumption to avoid abuses or to balance load between users? This QoS can be implemented on servers or on game, slowing down the response from the servers and consequently, slowing and acumulating threads related to download info (specially accelerating time 4x-8x).

This can be compatible with slow data loading times and game waiting for those internet-related (or maybe other game related) threads to close, dropping GPU usage.

At first I thought it was a memory leak, as with previous updates to SU10, memory increased until 40GB and game crashed (I have 64gb) but after some updates, that memory leak seems solved, nevertheless fps drop is still there over time.
The good thing is that it does not crash anymore because of memory increasing (specially accelerating time).

This happens since the game was released, at least this happens to me since the first day.

Maybe we will have the issue fenced some day :slight_smile:
Thanks to Asobo and all this great community for the effort.

1 Like