AI engine is now substituting aircraft of the same model with a different livery when in offline AI Mode

Since WU 4, the AI engine is now substituting aircraft of the same model with a different livery when in OFFLINE AI Mode.

Scenario:

Default AI Traffic file disabled
AI Traffic set @ 100%
Only one AI FP generated installed containing a single B738 model (QFA)
Only 1 aircraft model installed in the Community folder (2 different Liveries) QFA and SJI
Refreshed layout.json for both aircraft and Custom AI traffic
Restarted Sim

  1. With both aircraft active, at a given airport sim displays 9 x 738’s on the ground (4 x QFA and 5 SJI)
  2. When SJI Livery is moved from the Community folder, 9 x 738’s (all QFA) are displayed which is the expected outcome, according to the Compiled FP

When the SJI livery is returned to the community folder, the AI engine is substituting SJI livery for some of the QFA ones, as in 1) above. The SJI livery is NOT included in the compiled AI FP

Can anyone else confirm using examples of thier own (I aircraft model, 2 different liveries, 1 AI FP containing only the 1 model/livery?

Same problem here. Everything was ok before WU4.
Now the sim reads well the flightplan, so origin and destination are correct. Model and registration number are correct. Livery is absolutely random, ignoring what is indicated in the compiled bgl file! Really a lot of steps backward! :sob:

1 Like

Same here.
I wonder if Asobo are moving from reading the title line of the FP to reading the icao_airline…
I have this bad feeling.

1 Like

I’ve edited all the icao_airline values but still no matching :confounded:

1 Like

Yeah, I think this is definatley an issue that is in the AI engine source code and no amount of trickery or file manipulation is going to fix this :frowning:

I have just installed a Singapore airlines AIFP that contains the 773 and going to WSSS now, the airports should have a lot of Singapore 773’s there, but there is only 3 on the ground, but a heap of other airlines 773’s there as well, as my 773 folder contains quite a few liveries, so same thing happening

I have just also noticed that changing the weather at any airport results in the AI aircraft changing aircraft and liveries parked up?

OMG , This messed up , ATC speaking in weird text and even german phrases in english , Multiplayer causing massive stutters all since WU4 …totally unplayable
Fix it NOW Asobo

Absolutely agree. It is very frustrating when suddenly from one day to the next nothing works anymore and the AI traffic no longer follows any comprehensible logic.
Should be fixed as soon as possible by Asobo.

Sunny greetings from Berlin

1 Like

Another observation I just observed. I have caught the sim RANDOMLY selecting aircraft! On changing the date slider, the existing aircraft dissapears, as you would expect then, within the space of 1-2 seconds, another aircraft appears for a split second, then a different one a split second later, then another which stays put, all this at the same stand!

Here is a short movie of it in action. Watch the ANZ All Blacks aircraft. Happens toward the end of the clip as couldn’t edit it to make it shorter (77mb download)

I really would appreciate it if Asobo maybe even put World Updates on hold while they concentrate (for once) on sorting out everything to do with A.I. in MSFS 2020 - Traffic, Co-Pilot, the way ground vehicles clown about in the Airports, and the livery and plane issues you’ve highlighted here. It just needs some earnest attention.

1 Like

A lot of the devs working on World Updates aren’t the same ones working on the Sim updates IIRC.

Either way I believe they said that from now on Sim Updates and World Updates are going to be released at the same time, they’re not alternating them anymore (that’s either starting next update or the one after, I don’t recall)

Bug Report AI Model Texture Substitution

System: AI
MSFS Version: 1.15.7.0 / 1.15.8.0
AI System: Offline
AI Content: 3rd Party (built-in traffic disabled)
Reported by: JanMartinHamburg (Member of AIG)

Description:
Since MSFS v1.15.7.0, custom AI aircraft models are partially substituted with a random texture that does not match the texture it should show, according to the ICAO airline code given in the flightplan BGL and the aircraft config file. This results in for example United Airlines B737’s flying in Europe or Lufthansa A320’s flying in Asia. Substitution of AI aircraft with the correct texture was given prior to MSFS v1.15.7.0 update for all AI aircraft; after the update, about 40% to 60% of all AI aircraft are being substituted with a wrong texture now.

Steps To Reproduce:
Setup of custom AI traffic like it was, respectively is used in FS2004 / FSX.

3rd Party Content:
General AI aircraft models from various modellers (FAIB / TFS / AIG / AIA) with custom handmade airline textures and AI flightpans from usual sources compiled to BGL format.

Current Workaround:
No workaround was found by many MSFS AI traffic enthusiasts.

2 Likes

Hi guys, has anyone of you installed the latest Patch 1.15.10? Any improvement on the offline AI traffic side? Thanks

No, still substituting different liveries, sadly

I was really hoping that the patch would solve the issue
:sob: :sob: :sob:

The issues described in this thread is very important to fix.

ATM the reality and immersion of the sim as a whole, is very lacking due to the complete lack of realistic AI-traffic. Come on, a live Dash 8 trafficking my local airport show up as a B747.

Many of us simmers strive to generate realistic airport environments, and its’s just ruined by the fact that generic models with generic liveries populate random gates.

High on my wish-list, is the ability to import FAIB, TFS, FSPXAI FSX-models, and the ability to assign a lot of texture-folders and only have one model-folder per model. Today this can be achieved by manually adding one model-folder per one texture folder.

I imported the FSX FAIB 737-800WL model with 587 separate textures, and I had to add 587 model folders and putting duplicate corresponding model-files and model-describiton into each very one of them.

This actually works, but i s very time consuming and completely ridiculous from a computer programming point of view. This approach also make the startup scan of the sim painfully time-consuming.

I hope Asobo reads this, and not only prioritize real immersion in trees, bushes, buildings, lighting and weather, but also on this important topic

forwared this alread to ASOBO via Jörg. No clue who came up with this design choice of having a unique model per fltsim…

1 Like

You’re absolutely right, but prior to modify the whole architecture of AI traffic, it would be great if Asobo fixed the issue relating radom textures. I’ve spent many days to create my custom traffic and it is absurd that everything was quite satisfactory and now I gest random liveries everywhere. They may have priorities in adding new features, but it’s absurd to break what was working correctly! :sob:

2 Likes

So far no improvement. Even SU4 has not solved the issue. Still absolutely random liveries are chosen. What a shame! :sob: