AI pilot won't talk to ATC

#pc #steamversion

Hi! When I select the AI pilot to talk to the ATC, he/she won’t do that… I have to do it by myself. Can someone help me?

The AI pilot will not talk to ATC unless it knows what the intent of the user is. It seems to get this information from a flight plan set up from within the World Map, or perhaps a flight plan loaded while in the World Map. If you load a flight plan manually into the GPS after entering the cockpit, that does not seem to inform the AI, so it still won’t know your intent or make calls to ATC according to the plan.

That being said, there are ways that the AI can become informed about your intent and will then go ahead and make some calls for you. For example, if you choose a runway to land on at an airport, the AI pilot will call in with your position from the airport and your intention to land. If you have announced that you are taxiing to a certain runway, once you reach the holdoff point and stop, the AI will call the tower to say you are at the runway, ready to take off.

I’m not certain about all of this, but this is what I’ve been able to discern from my experience with the feature.

1 Like

Usually, you need to turn off the Copilot ATC assist. Then go back to the main menu. Start your flight again, and make sure the Copilot ATC assist is still off before you start-up the battery.

Then do your pre-flight activities, and when you’re ready for the ATC to handle the radio, turn it on again and you should be good.

I find that it tends to cause some issues when you have it turned on, then you turn it off, and you want to turn it on again. That’s why it’s better to start them with OFF, then do things yourself, including getting ATC clearance. Once you’re ready for them to handle the ATC, switch it on.

Also, remember to switch it off before you park. Because sometimes the sim thinks you’ve parked and want to start another flight, so the ATC asks for pushback again even though you just arrived.

1 Like

Did you try these steps? Go to Options, then assistance options, then piloting, then make sure you have AI Radio Communications on. Then when you’re in the flight, you can also go to the flight assistant and make sure AI assistance is also set there.
ATC is not really working well right now though. Let’s hope it gets fixed in the next Hot Fix.
Good luck.

1 Like

I do exactly that, turn it of before the flight. But then the copilot asks for puschback, and I don’t want to be pushedback at exactly that point. So I use to cancel the puschback by myself and after that, the AI pilot won’t talk to the ATC.

Turn it off before the flight? But you can’t open Copilot ATC assist open until you’ve started the flight. Perhaps there’s other things affecting it. See if you can make sure all your assistance settings is set to Hard/True to Life first from the main menu. Then start your flight and open the assistance icon from the top toolbar. Make sure everything is off in there. Then start your battery and do your preflight activities.

As long as it’s off, the Copilot ATC assist shouldn’t trigger on its own without input.

I find that when flying VFR, the copilot handles everything as expected but now rarely contacts the arrival airport to set everything up 11 miles out or whatever. I have to do that myself. That started a few “improvements” ago.

Flying IFR I don’t have that problem

It has also happened to me. I made a flight plan from London to New York and found the AI pilot assist was not available. I activated it and disabled it, then enabled it again, to no avail. This was during the whole flight. It crossed my mind that it was to make sure that you had to follow all instructions as it was a long haul flight and I wonder if it is designed on purpose to keep you alert?