AI radio communications (ATC) gets set to ON, even after I set set it to OFF

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting.
Yes, only a few, and I didn’t change anything for weeks, so it’s SU5 related

Are you using Developer Mode or made changes in it?
No

Brief description of the issue:
In Assistance Options, Piloting, the AI radio communications (ATC) gets set to ON, even after I set it to OFF.
When I set it to off it stays to Off, but after a while or after I restart FS, I often have it set to ON, although I never set it to On myself.

Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered:
Set this option to off then check it each time you use FS.

PC specs for those who want to assist (if not entered in your profile)
i7 5960X
GEFORCE RTX 3090 TUF GAMING OC 24GB
FS client on C:
Data on D:

Build Version # when you first started experiencing this issue:
1.18.14.0

Are you on the Steam or Microsoft Store version?
Store

Did you submit this to Zendesk? If so, what is your ticket #?
No

Do you turn them on from the AI Assist on the top menu bar? If you set them on during a flight without turning them off manually, it will stay on and changed your assist settings.

1 Like

What is the AI Assist on the top menu bar exactly?
Tonight, I used the ATC in 4 flights, AI radio communications (ATC) remained to Off.
After a few landing challenges, I checked, and the AI radio communications (ATC) is set to On.

I just can’t find out what set AI radio communications (ATC) to On

I have the same problem. I turned it off but sometimes it activates itself again. I always have to check if it is still turned off when I launch the sim.

1 Like

The top menu bar is the menu bar when you hover your mouse on the top side of the screen. You should see many icons on that bar like Active Pause (at least) and other things like Weather (if not on Live Mode) then ATC, Objective, Checklist, etc. One of them is an icon that looks like a pilot’s head. That’s your AI Assist settings for that flight which usually goes back to the general assist settings.

1 Like

Thank you for clarifying! :+1:
This:
image

Then this confirms there is a bug somewhere: I haven’t used it yet in Sim Update 5, because I did mostly a few landings challenges, and flew aerobatics with the Extra. No need of a co-pilot with the Extra.

All off here:

Edit: maybe it could come from the Isafjordur Landing Challenge: AI radio communications (ATC) is ON after doing that challenge…

I did more testing, and it gets set to on when doing landing challenges.

I have the same problem and it is really annoying when flying online when the frequencies are constantly being changed. Why do they develop such garbage that nobody needs?

1 Like

Do you mean this:

This issue has started happening for me also. I have resorted to checking it is set to “off” before turning on mains power as even if I have it set to off, it seems to want to turn itself back on the next time I launch the sim.

Edit: I can confirm that for me running a landing challenge changes my preferences in Assistance Options, Piloting, AI Radio Communications (ATC) from OFF to ON.

1 Like

This issue started from SU5.