Aileron input from yoke goes crazy

Since today I have an issue with my yoke. It’s an Saitek Pro Flight.
It worked the first flight today but in that flight I decided to make some changes in the Sensitivity settings for the ailerons.
After that it has been going crazy.
While in the Control Options - Sensitivity page all is fine. The graph showing the response to the input I do with my yoke looks just fine hence I don’t believe it’s an an issue with the physical yoke.
It’s when I return to fly it doesn’t work as expected any longer.
When I move my yoke to the left, the yoke in the plane just moves like 1 or 2 degrees to the left and then no more. When I move my yoke to the right the yoke in the plane moves just a few degrees to the right but then if I continue to move my yoke to the right the yoke in the plane moves all the way to the left, that is all the way in the opposite direction. If I have the outside camera and looking at the plane I can see the ailerons act the same way.
The rudder (up/down) act as it should do and also my throttle control, spoilers etc.
I have cleared my Community folder, logged out of Store and Xbox, rebooted the computer and then logged in again but the problem persists. I have also checked that I’m in Modern flight model.
I have tried with the A320 and two different GA planes. Same thing in all planes.
So any thoughts on this? Any hints?

Moved to a Self-Service peripherals for better visibility.