Aircraft Failures "Armed" values won't register #XBOX

After I have turned “Enable failure” and “Armed” to ON, any value put in to “Fails in (minutes)” and “To (minutes)” won’t stick after I close the menu.
It’s back to “0” again when you open the menu.
Every aircraft and different failure I have tried, has the same outcome. The aircraft spawns with that failure, as it thinks you armed it to fail from 0 to 0 minutes.

This is still present after SU6.
No replys to this topic, so is no one else having this problem?
Come on Xbox-crowd! Can´t belive Im the only one.

4 Likes

I,m having the same problem.
It occurs with every airplane.
I’m also playing in Xbox

2 Likes

YES! Thank you!
I belive this is an easy fix to get the values to stuck, but not so easy to get people to pay attention to the problem.

2 Likes

I am having the same problem. Any solution?

3 Likes

I bought an Xbox over the Christmas period and I am having the same problem which is a real shame. Did anyone discover a solution to this bug?

2 Likes

No solution found and it’s not solved after the last update.
It’s still occuring in the beta test environment too

2 Likes

Same issue. Should be an easy fix.

1 Like

I have the same issue. I play on Xbox Series X. This feature never work since the launch on xbox.

1 Like

Let’s keep activity up on this thread. Day one bugs should be fixed by now and MS should acknowledge this persistent, easy-to-reproduce bug.

I’m gonna drop MS a bug report and I suggest everyone do the same.

To send bug report (can’t paste link here):

  1. Google “flight simulator FAQ”
  2. Navigate to top result (zendesk page)
  3. Navigate to “How to report a bug”
  4. Click on the link “Fill out the big report form”
1 Like

Dear all, im on the xbox series x, ive been trying to post the sane issue and i have exactly the same problem and i want to get it fixed

1 Like

Yeah this is getting ridiculous. It’s a bug that’s been present since day 1 and across updates, is easily and consistently reproducible, and (presumably) very simple to fix.

See my post above on how to submit a bug report, since this thread obviously isn’t getting any attention from MS.

Same issues failure set times dont work on xbox

Still
Not working