Airliner avionics shutting off mid-flight

no fix atm, its definitely a bug, just keep saving in flight, and call it “save” each time, so it overwrites last one. when it shuts off just restart and reload. Use active pause to get your autopilot set up, and make sure you throttle is in the right position (sometimes it idles).


Just happened to me, everything in the aircraft a320 shut-off, I’m wondering if I killed the battery or there was a fault mid flight? Or just a bug in the sim?
Still enjoy the experience however it’s hella scary.

Just happened to me, everything in the aircraft a320 shut-off, I’m wondering if I killed the battery or there was a fault mid flight? Or just a bug in the sim?

happends to me flying the TBM This is driving me nuts… cant fly my fav plane :frowning:

I had the same issue, i found out it issue was my TCA throttle quadrant and what the engine starters was bound to. I made a new profile for joysticks on each plane i use

1 Like

Good evening, as you can see from the photos, it happened to me too with the KingAir 350, but you can solve this Bug, This game is disgusting, it is to say that I paid 120 €, how sad, to give a negative vote, to this game .

This happened to me yesterday once on the Diamond DA40. No rhyme or reason as to why it turned off mid flight. The only thing I can think it may be attributable to, is the fact that on that flight, I started cold and dark. I checked every possible switch, and everything was enabled as it should. All failures are toggled off. It did now happen on any subsequent flights when I was starting on the runway.

Seems like a tough one to re-produce. If someone has any suggestions for what to turn into the @zendesk when something like this happens, I would be willing to submit anything to help.

Currently on a 4 hour flight in the A320 and it’s just happened to me again. Bored of this now. How can this be happening still in the game without a basic fix? I’ve tried everything. This seems to always happen on long flights. 1 hour or less, nothing.

I recently conducted a $2500 US upgrade to my PC. New mobo, processor, GPU, RAM, basically replaced everything except the hard drive that the OS is on. FS2020 even has its own M.2 harddrive to run from…

And this is STILL happening. I couldn’t even get off the ground from KATL in the stock A320 before the avionics went dark. Only recourse was to turn the AI on and let them fly.



do you have TCA quadrant?

My FMS and auto-pilot is total POS. A320, CJ4 and Longitude randomly follow the flightpath. Flew A320 from KATL to KDHN today via VFR high altitude airway, was assigned my runway and approach about 65 miles out. I entered the runway and transition, and the A320 totally veered off course in circles.

Microsoft had most of the bugs worked out until the recent Xbox integration, now things are worse than ever. Very disappointing.

It is terrible, not sure how the Xbox version works.

Hi, when on approach or final with A320 Neo I loose all displays and the navigation panel, total black-out. The screens return for 1-2 seconds by moving the camera position with right button of the mouse. This occurs in 95% of the A320 flights.


1 Like

Hey Swordsman. Just wondering if you are still experiencing the avionics issues. I just installed MSFS 2020 on my brand new PC a few days ago. I am running Windows 11 and everything is up to date on both Windows and FS. I have also been experiencing these avionics issues. Usually, one of my G1000 screens goes blank, or just shows the logo, and sometimes I lose both. It seems totally random and very disappointing…especially since this issue seems to have been plaguing this game for a while now. I’ve got the latest version and it is still an issue. I have yet to see a solution for this…any ideas? Thank you.

Hi I play on the Xbox Series X and if I load in and do a flight from cold start the plane will turn off around 30 minutes into the flight every time but if I spawn in with the plane ready to go on the runway it never turns all the electrics off.

Does anyone know how to fix this as I like doing flights from a cold start.

Me too, still happening ! I thought it was the mig 29 market plane but apparently not ! Very bad how this major bug not been fixed

Happens to me A LOT

Just stumbling across this bug. I never had it happen to me, but it reminds me of another I had in a different game that was the result of an unused, but plugged in game controller messing with the game. So I wonder if you guys somehow have a gamepad or a Bodenar controller etc. being recognised as “GEN ON” or something.