Airliner avionics shutting off mid-flight

I stopped playing because of this bug back in September of last year. Here we are 8 months later and it’s still a problem for me. I had the FBW A320X but got rid of it since I had read it could cause problems, and I still have them.

I’ve been constantly testing over the last two days to see if I could tweak the problem away. Had one flight in the 787 from Sydney to Auckland and another just now KJFK to TNCM without issue, but every flight in every other airliner, stock or aftermarket, the avionics and electrical systems shut off unless I have the AI fly the plane, and after that, what’s the point?

I have the AI traffic set as offline and using generic aircraft models per some of the other posts I have read, but that does not appear to solve the problem. The only community mods I currently have installed are all livery packs for the stock aircraft. I only own 2 aftermarket planes in the CS 777-200 and the BRED0K3D 737 MAX. The avionics issues extend to these as well. I also made sure that all of my products are up to date. Just in case, I renamed my Community folder, locking out all of the mods just to be sure and then test flew the A320, experiencing the bug while taxiing to the runway to depart.

Is anyone else still experiencing this problem? Or any suggestions as to a fix?


Are you turning on the generators? Sounds like the battery is going flat?

I’m going through the complete startup checklist and generators are indeed on. It doesn’t happen at any specific moment in the flight. It can happen at any time from taxiing to the runway all the way to final approach at my destination. The only airliner not affected is the 787 so far.

1 Like

Hey mate

i just got same issue with all my twin props, garmin 1000 and other gsn540 and trans sponders switch off after 20 sec,any chance you got flytampa sydney,?I going uninstall my flytampa see if thats issue

Thanks. I do not have any aftermarket scenery. Just the Premium Deluxe edition and two airliners for now. Only mods I have are the livery mega pack, which is V12 so up to date.

ok ,good luck i think i just fixed my issue,updated FBW installer

I am seeing same issue with C172. This has started after update 4.

I managed to fly a full route without problems with the 747-8i, but the stock A320, and aftermarket 737 and 777 are still affected. I just spent an hour flying from TJSJ to KMIA, and half way there, I had to turn control over to the AI copilot if the avionics and radio weren’t going to shut off. Soon as I took control again, the jet shuts right back off. No point in continuing. This is truly obnoxious. I paid for a flight sim, not a passenger sim, which is basically what I’ve got if the AI has to do all the flying. May as well load up the 777 and use the POV camera in coach.


Try uninstalling FBW, and downloading new FBW and installing fresh Into communities folder. If I remember properly, one of the bugs that was cleaned up within the past 3 to 6 months or so was an electrical system glitch.

If you still have this glitch in the version you are running, this could cause your avionics to run out of juice.

1 Like

Thanks. Tried this. The FBW A320 works fine now. Oddly enough my initial installation of it was about a week ago… and the stock A320 and two aftermarket airliners still have the problem. At least I have one short-haul airliner that is functioning properly, though.

1 Like

I have a new install of MSFS 2020, version 17.3.0, I don’t know about the Airbus A320 but I’m seeing this issue with the Boeing 787, and the Beechcraft King Air 350, and I believe I saw it with the Beechcraft Baron 58, but I haven’t seen this with the Cirrus SR22, the Cessna 172. I don’t have the FBW installed but will this resolve the issue for every aircraft that experiences it?

1 Like

No. The FBW A320 works fine for me, as does the stock 747 and 787, but the stock A320 and aftermarket 737 and 777 still have this issue. I have not tried it with the prop or turboprop planes yet. I typically either fly airliners or steam gauge pistons.

1 Like

Thank you. :+1:t2:

I have the same problem that the avionics of the plane turns off … I fly with the 747 and 777-300 and in the middle of the cruise everything turns off and there is no way to restart the apu, accident assured.
Why is this still happening today?

This is an across-the-board issue that has plagued the simulator from day one. Electronic sytems or avionics randomly shutting off and requiring a reload or sim restart to fix.

It’s happened to me with every aircraft I’ve flown, which is all Asobo bush planes, the Caranado 172 and Ovation, the Caravan and now the PMDG DC-6.

It’s a joke that this bug does not get more attention from either the community or Asobo and it feels as though it’ll never be fixed.



for me, it has only happened with the KingAir 350 so far. Not for others such as C172, C208.

This happens to me to! It used to be once in a while, now after the latest hotfix it is every flight. I find that the avionics just shut off during the end leg of every flight (doesn’t matter the duration 3 hours or 30mins). It can happen when descending and flying the STAR, or when capturing the localiser for final, or later while on the glide slope. I haven’t tried in smaller aircraft, as I’m a sucker for airliners.

Happens on xbox as well. A320 has this every flight, at random intervals so not a specific memory issue as far as I can tell.

Checklists either completed manually, auto engine start, or on runway to start flight has the issue, so it is NOT a battery or generator issue from what I have worked through

Same issue on Xbox with A320 and the TBM. Any fix on the way from mfs still ?

I have this same issue on series S with all airliners. Has anyone figured out a solution?

I’ve triple checked checklists, made sure buttons weren’t mapped funny/switching mid flight or the screens were just dark, turned off all traffic and data caching, and even tried reinstalling… Let’s just say I only fly bush planes now - Between the vanilla ATC wanting you to be an F-18 and the FMCS planning circular flight paths IFR on Xbox is super disappointing.