Airport information

Hi everyone, I watched a tutorial on YouTube where the guy was able to get airport information like the ILS frequency from the G1000.
On my screen that option is not highlighted and I can’t select it, someone knows why? Does anyone have this problem?

Moved to General Discusion. #community:general-discussion-feedback

He is probably using the G1000 NXi mod, available in the marketplace for free. Can you post the youtube video? Maybe it is listed in there?

Here the video

I’m using the same, but looks he has way more options then me.
I don’t know if that has to do with my settings :thinking:

Hmm, it’s a pretty thorough video so I’m not sure why you’d be missing those. It doesn’t look like he mentioned having Navigraph data either, do you have that installed?

I would try the G1000 NXi available for free in the marketplace. Just make sure you don’t have another G1000 mod in already.

There are also tons of resources for getting frequencies. I would recommend LittleNavMap, or pulling up SkyVector.

If you have an android phone/tablet, or even iPhone/ipad I would install FltPlan Go. It will provide approach charts and has a moving map that follows your airplane and connects to the sim. It is free and is used by real-world pilots.

The g1000 I’m using is the one from the last update, I actually installed fs2020 just a month ago so could be I’m missing few things.

Fltplan go sounds pretty interesting, I was actually looking for an app where to find airports approach plates. Thanks for the advice

If you’re talking about a “stock” G1000, are you looking for the information shown on the screenshot below? You can get this from the standard G1000 if that’s what you’re after.

1 Like

Yes those information, how do you get that? Do I need to change something in the settings?

There are two different ways to get this info, depending on how far away from the airport you are.

First, for airport NOT near you, use the Large FMS dial to select the “WPT” page (you’ll see the page names at the bottom the screen as you’re turning it and then the labels will go away if you stop). Press the end of the FMS dial to activate the cursor, then use the small FMS dial to select the first letter of the airport ID you want to use. Use the Large FMS dial to move to the next position in the name (it will go both ways once you’re past the first letter in case you need to go back and correct an input). Once you’ve got the second position selected, use the Small FMS dial to change letters/numbers (it rotates both ways), and keep changing positions, and letter/numbers until you got the airport ID inserted, then push the end of the FMS button to select that ID. Press the end of the FMS again to activate the cursor, then use the Large FMS dial to rotate through all the info available. It will move to the next category by itself as it reaches the end of one info block. Once the cursor is on the info you want (e.g. the ILS freq for the airport you want), push the “ent” button, and that freq will be entered into you Nav 1 standby freq for use later. Same with comm freqs. If you happen to push the end of the FMS dial, it will deactivate the cursor. Just push it again to activate the cursor and go back to what info you want.

Second, for airports near you, on the MFD, use the Large FMS dial to select the “NRST” page. You can use the softkeys at the bottom of the page to select the airport, runway, freq, or approach you want to chose, and use the Large FMS dial to rotate through the info in each block and use the ENT key to put the comm/nav freq in the standby position on your panel.
There are some other variations you can use, but I’d advise you to just play around with those dials, buttons, to see what they do in different conditions.
I’m giving you a lot of that by memory, so let me know if you need more info, or just play with them until you see the logic of how they rotate/select various data point.
Hope this make sense to you. Let me know if you need more into.

The problem is that I can’t select anything, won’t let me do it

See what I mean nothing is highlighted

Ok, I use the “Legacy” version of the mouse selector, so I get arrows to turn the dials, and a normal mouse pointer to “push” things. I haven’t really tried the newer mode, but hopefully someone will come along and talk about how to do what’s needed to get it “selected” using your mode of mouse.
P.S. I’m going to quote @Synoxys787 from another thread on using the new mode:

It’s a new interaction method called Lock. It happened in SU5. The basics are as follows.

Highlight a control (like a knob)
Hold LMB to lock to that control. Now your mouse will not affect any other controls or other mouse bindings
Move the mouse left to turn the knob left, move it right to turn the knob right (with LMB held down)
Alternatively, use the scroll wheel while holding LMB down to turn the knob left or right
To push a control in, lock to the control using LMB and then right click
There is an option to go back to the way things were before, called Legacy. It’s in the settings menu. However, I honestly enjoy lock much better.

Thanks for your help mate, but still doesn’t do anything, I wonder if is any problem from downloading it or something in the settings :thinking:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.