Allegiant Callsign Doesn’t Work (Censored as Explicit)

,

Please tag your post with #pc and/or #xbox.

Are you on Steam or Microsoft Store version?
microsoft store

Are you using Developer Mode or made changes in it?
No
Brief description of the issue:
Allegiant Air callsign “ALLEGIANT” gets marked as an explicit word and you can’t save it on ATC screen
Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered:

Try to insert “ALLEGIANT” into callsign. If you get it to work ATC screen will show ******* then the flight number

PC specs and/or peripheral set up of relevant:

Build Version # when you first started experiencing this issue:

It could be a licensing issue. Either not allowed by trademark owner or not approved for use by Dev.

I don’t think so because ATC uses the call sign for Live AI traffic. I just can’t type it in as my callsign

1 Like

Just throwing it out there. Maybe it’s to avoid confusion when it comes to ATC instructions. Have you thought of trying other Airlines to see if there’s a conflict?

Other airlines are working ok

1 Like

I wonder if there’s a list of “No-No Words” somewhere. Why not try letter and number combinations? Looks like you’ll have to make a compromise for now. It’s very odd. What’s possibly wrong with Allegiant and how is that offensive language? Way heavy handed. Just hope that it’s a bug that’ll fix itself or something.

Maybe a dev really doesn’t like that airway or the Divergent series of books/movies :rofl:

Yeah, who knows? :man_shrugging:t2: I just went with the three letter airline code with a flight number for now. Just kinda annoying when you’re flying and another plane on the ATC comm is called Allegiant, but here’s you with “Alpha Alpha Yankee” :rofl:

I had the exact same problem with Allegiant the other day (only callsign that did this). I just tried it right now and it works fine.

Hi there,

This happens to me on Xbox, so in that case could you update the tag with #Xbox? This is quiere annoying how the Allegiant call sign is censored.

I don’t think it’s an Xbox exclusive issue though. Seems to be server related. Must be an incorrect explicit flag on the text to speech setting from Microsoft. Added Xbox as well

1 Like

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

no

Have you disabled/removed all your mods and addons?

yes

Brief description of the issue:

Allegiant callsign will not stay in the customization box for callsign

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

restarted sim 5x

PC specs and/or peripheral set up if relevant:

12700k , 2080ti , 32gb ram , windows 11

Build Version # when you first started experiencing this issue:

Su10 but it was happening in SU9


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

Still happening :roll_eyes: