Altimeter and flight level disparities

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting.
Tested with and without add-ins. Same results
Are you using Developer Mode or made changes in it?
No.
Brief description of the issue:
ATC reports my aircraft not at assigned altitude repeatedly. I have to adjust altitude by 400-600 feet in order to shut ATC up.
Provide Screenshot(s)/video(s) of the issue encountered:
Not applicable
Detail steps to reproduce the issue encountered:
File and execute a flight plan going above transition altitude (US = FL180)
PC specs for those who want to assist (if not entered in your profile)
Ryzen 7 3700x/16GB memory/RTX 2060 Super 16GB
Build Version # when you first started experiencing this issue:
1.18.14.0
Are you on the Steam or Microsoft Store version?
MS Store
Did you submit this to Zendesk? If so, what is your ticket #?
No

What is the possibility you forgot to reset your Altimeter? :smiley:

Easy settings:
Go to your Controls > Set Filter “ALL” > Search by Name

  • Find the one says “SET ALTIMETER TO MSL PRESSURE” assign a button to it e/g CTRL+B after FL180 press it.

When you descent and go below FL180 adjust it to the airport altimeter you are gonna land before you approach, ATC going to give you the value.

same situation here…

1 Like

Currently in flight with the same issue. Have the “Set Altimeter” mapped to my yoke so I know it is correct. My initial flight level was 7000 FT, ATC kept bugging me to expedite my climb despite being at 7000. Eventually was told to go up to my cruising altitude of 12000 FT and just ended up waiting for them to tell me how much I was above or below and adjust accordingly. My altitude has ranged from 12200-13000 FT during this flight, constantly having to adjust a few hundred feet every 3-5 minutes.

At first I thought it was reading my altitude based on ground level, but later that didn’t add up either (have The SkyPark on the side which shows that)

4 Likes

Same Problem here… This bug is very annoying, hope it will be fixed soon

2 Likes

Same here, flying anywhere from 4,000 to 8,000 feet and ATC usually yelling at me for being 300 feet to low and once making me climb to 8900 feet when I was supposed to be at 8000. Altimeter is set correctly, little nav map reports my attitude correct, but ATC says I’m too low. This is very annoying, especially since the numbers keep changing.

1 Like

See this thread

2 Likes

I thought it was just me. ATC looks like it’s stuck reading the altimeter below FL180. I filed FL 440 and when I got to flight level 260, which is the altitude I was assigned, it kept saying to expedite to FL260. I had to go above flight level 260 (maybe 26,300) for it to stop telling me to expedite my climb. Once I got to FL440, it kept saying to expedite my climb to FL440. Once I had to climb to 46300. Of course, when there were windshears that affected the altimeter below FL180, it told me I was either below or above my assigned altitude and I had to make corrections.

On top of that, on my flight to Fairbanks, AK, about 300 miles from Fairbanks, I couldn’t hear ATC any more. Luckily my copilot could still hear it so I had to rely on him.

Initial thoughts, after running some tests:
Barometer settings are reversed. When I am above FL180 and set 29.92, my altitude is off, according to ATC.
When I am below FL180, and Barometer is set to whatever is local (pressing B to automatically set Barometer). ATC reports my altitude is off.
So, I set 29.92 below FL180 and area Barometer while above FL180.

Another baffling part of this is when traffic is reported to another aircraft, ATC give an altitude above my assigned altitude. i.e. My assigned altitude was FL410 and ATC kept telling me to expedite my climb to FL410. I was at FL440 when ATC reported me at FL430. I started to descend and was again told to expedite my climb to FL410.
ATC just told me I as 300ft above FL410. I am actually at FL430 (29.92).
I lowered my altitude to FL427 and after a couple minutes ATC reported me 400 feet below assigned altitude of FL410. I am now climbing to FL431.

I am currently trying to capture a video to prove this.

1 Like

No need to spend time making a video or providing further “proof.” The issue and the fix are already known and being worked on. See the message 2 above yours.

1 Like

Same for me . Do you noticed that you can’t push the STD baro button you only able to turn it right and left (787). There’s also to many hugs after this update!!

There is also another bug concerning the baro standard settings in the 787 it now(After this update) impossible to push the baro button .you can only turn it right and left

1 Like

This is weird, I can push it. Nothing changed. (I am using legacy mode).
This is really weird, I don’t see most of the problems people see. When I search for the problems I have, it looks like no one having it…

I’m having this same issue. It’s almost like ATC is reading a different altitude or using a completely different value than what the aircraft is indicating. Not sure if it’s a corrected altitude that AI ATC is using, but if so, that is still incorrect implementation of how ATC reads your altitude.

Altimeter is set to the local setting when below 17,999ft and 29.92 at FL180 and above. ATC still says I’m “300 above assigned altitude”.

Worthless.

Hello everyone,
We are closing this issue, as there are already two linked threads in. the #bugs-and-issues category listing this problem:
Wrong temperatures
ATC telling me I am at the incorrect altitude

A hotfix is on it’s way for this bug. It should drop either Friday or Monday: Regarding Your Feedback + Upcoming Hotfix