Any solution to shimmering textures for 1080p users?

Not sure if I’m imagining it but shimmering buildings and water seems to be getting worse. Airport buildings are some of the worst, the whole airport shimmers on approach. Has anyone come up with a solution to this? I’ve tried nvidia inspector to boost AA etc but it doesn’t make any difference. I’ve tried every combination of settings in nvidia control panel to no effect. Is this just down to my 1080p monitor?