Anyone else experiencing regular crashes to desktop while in VR after SU5?

While VR performance is definitely better, it will eventually crash to desktop while flying in GPU heavy areas like NYC or Paris. Anywhere from 3-8 minutes, eventually my G2 screen will turn black as if processing/loading areas (not uncommon) and then a second later crash the game.

I’ve tried reinstalling the update, removing addons, flying without AI/multiplayer traffic. All drivers are up to date. This didn’t happen before SU5.

Any help would be appreciated!

Which GPU are you using? This used to be a huge problem for AMD GPU users with G2. CTD every single flight. But, the SU5 finally fixed it. It probably has to do with how the XBOX now utilizes AMD GPU. Seems like now many NVIDIA users are having the CTD issues that they never had.

1 Like

Hmm… maybe I should be happy not to have obtained a 3080 Ti card as of yet in the Newegg Shuffle?

I was wondering myself if the XBox use of AMD over Nvidia GPU might force MS/Asobo to finally notice and address our CTD issues.

Yeah, NVIDIA card here, 2070 SUPER

I am experiencing frequent CTD’s too. RTX 3080 I9 10850k 32GB ram Quest 2.
Interesting thing is that this time Oculus link is stable and does not crash, but the game itself is.

1 Like

I had a brilliant flight immediately post update. Better than ever fps, smoothness and clarity in VR (10900k, 64gb ram, 3090, g2). Then I started to add some mods back in and I ended up in a CTD fest like I’ve not experienced before. After a bunch of typical troubleshooting, I somewhat accidentally stumbled across a problem in Content Manager. The World Update updates, which had seemed to go smoothly and completely earlier in the day, were showing up as being only partially installed. I’ve no clue what that even means or how it happened but I went ahead and set them to download and install. That complete, I closed and reopened MSFS. Since then, no CTDs, no other issues. ¯_(ツ)_/¯

1 Like

I am get CTD every 20mins never had it before.
Also getting the egg timer all of the time.


Try using the G2 with SteamVR’s OpenXR not WMR. This fixed most of my VR crashes.

Nvidia 3090
AMD 5600x
M.2 Samsung pro
1000watt power supply
32gb ram

Oculus quest 2 with and without tool tray.

With CTD and egg timer.

Otherwise very good experience and smooth.

Yes, unfortunately I can confirm that.
Constant crashed over London.
Three attempts, three crashes with CTD and egg timer.
I didn’t have a single CTD before the update.
My system:

Oculus Quest 1
Nvidia driver 471.41

Intel® Core ™ i7-9700KF 8x 3.60 GHz

6 GB NVIDIA® GeForce® RTX ™ 2060

Sounds good, will try that after work.
Thx for the tip. :+1:

Had similar problem. My was crashing the game as soon as I tried switching VR on
Other VR games were fine.
Followed MrZoops advice and that cured it. Finally with the new update in place the VR looks AWESOME>

1 Like

How do I do that? I have the game through steam but it doesn’t use SteamVR currently.

Go into Steam VR settings, then developer and you can set it to Steam.

1 Like

Hi, i5-10400F, RTX3070, 32GBRAM, G2 Reverb User here
I am constantly getting CTD, one time after switching to VR at departure, one time even on loading a saved flight plan.
This is not the reason i bought the Reverb G2 for.
I am really angry and Asobo/Microsoft should make users able to switch to a previous version of the Sim , when the actual version is constantly creating CTD´s.
I am playing regulary now with monitor, but i am upset.
Better for Microsoft they do get a error description sent from the Sim when CTD, to fix the bugs

What ultimately fixed CTDs for me when going into Content Manager and updating the previous world updates and over items that for some reason hadn’t updated automatically with update 5. Hopefully this works for others!

I spoke too soon. Since the first “hotfix” following SU5, the sim no longer even launches on my PC!! Had one whole week of no CTD’s, thinking my long nightmare was finally over, and now they go in and completely break the sim for me. Thanks, geniuses!

Post SU5 I wasn’t able to complete vr flight and ctd every 5-30 minutes. After the update it has been rock solid.

Using amd 6900xt .

Ok Guys, Command back! :smiley:
After the newest hotfix, no CTD anymore but smooth fps around Vienna and landing in LOWW. The distance drawing could be better but will check the fps with higher settings (at the moment XOR 70 and render ingame 70)
Nice job on the hotfix, Asobo + Microsoft :slight_smile:

Got CTD in SU5, in Hotfix 1 and Hotfix 2. Not much in SU4.