Anyone getting this error message? “Trial license has expired.”

This is a new one for me and cannot find any possible solutions. Just started this morning - tried rebooting. logon logoff etc.

“This app failed to launch because its trial license has expired.”


Me too - does anyone know how to fix this?

Perhaps it’s a server error since you’re getting it too. I certainly hope we don’t have to reinstall.

Which part of the world are you (I’m in Canada).

I have the same problem.

xbox services looks green… somewhat with game pass ?

Updating the xbox app worked for me.

1 Like

the classic :rofl:

I restarted the computer and it worked okay for me

Yes’m Xbox app update caused this! Restart PC

Yep :eyes restart fixed it!

Same issue here, legit ran MSFS for a bit. then had to quit and when i tired to boot it up again, i got “Trial License has expired”. Updated the Xbox app and restarted. Still not able to boot up MSFS, even tried to repair and still at square one.

Finally came back for me. Restarted twice, no luck, but eventually just worked.

I restart computer, update Xbox and still with the same problem

1 Like

I too have this problem now and can’t launch MSFS.

Any fix? I’ve rebooted three times, same error.


I signed out of Xbox, signed back in, then did a reboot and it’s back up.

I’m using this simulator from the very first day and even this morning and now I receive one message like this…

Saying that I cannot open because mi trial licence is expired

They are crazy or what ??? I got the Premium deluxe from the very first day !!!

What can I do ??

Check here: Anyone getting this error message? “Trial license has expired.”

Sounds like temporary glitch. Try reboot PC or update Xbox app if you use that.

Same as others here…never seen this before! Hopefully a known issue, and Asobo / MS are on top of this problem. Multiple reboots, log-outs of Xbox App, etc…no remedy.

Must have been a temporary glitch. I came back to my PC 2 hours later to re-try, and now it starts like it always has. Very strange!