Arrival Airports, Traffic, and FPS Have Disappeared

I had this problem a couple of weeks ago. EGLL to EBBR in the fenix. Both airports payware. About 10nm out my fps started to drop dramatically until on finals and I went to about 2 fps and the airport had disappeared. I was running FSLTL and GSX and I tried disabling these and it was still happening. In the end I went back to DX11 TAA from DX12 DLSS and this appeared to solve it for me. Everything has been good in the half dozen flights since but reading this thread makes me wonder if I have indeed fixed it as my solution doesn’t seem to be related.
I7 10700 RTX3080 1TB NVME 32GB

1 Like

Had the same last to flights. EHAM (premium deluxe) > LOWI (ORBX) and return flight, in the PMDG 738. Running P2ATC and GSX in the background. Never had this problem before.

Wil try some shorter flights coming days to triage!

Ryzen5 5600X, RTX 3070, 1TB NVME SSD, 32GB RAM

Edit: this was at the pier at EHAM after landing

1 Like

I posted the steps I took to recreate the problem up in post #12 (I think it’s #12), so if anyone has the Fenix A320, AIG, GSX, FSDT KORD, and VerticalSim KOMA, please try it out, it’s about an hour flight time.

1 Like

This morning scenario if anyone wants to reproduce (SU11 no Beta):
Airplane: FBW A320 Development version Lufthansa livery
Departure: Stock ESSA
AI traffic: AIG with TC:
Time of departure: 6 AM
GSX: ONLY for pushback (no passenger boarding, no bagage loading)
Destination: EDDF (stock version with mod)
Ships AI traffic: NO

Upon arrival at EDDF, no airport building, no AI traffic (except on frequency).

1 Like

The last part is confusing. Why would we want to ENABLE the Airport Services in the Traffic Manager if this leads to more injected objects? Wouldn’t we want to do the opposite to reduce the risk of Simconnect reaching the limit?

For FSLTL users, can you confirm this happens? The sim in a ‘sleep state’ seems like an important detail.

The latest update of FSLTL changed the message to: traffic removed by MSFS traffic engine

because the number of injected airport services by TC is far lower compared to the one by the default Sim. If you can live without any service of AI you can just disable it in AIM.

1 Like

That doesn’t make sense, I’m afraid.

The supposition is that when the number of objects introduced via Simconnect hits a certain figure, all subsequent objects fail to load.

The tests to prove this are if:

Add-on A by itself causes no problems
Add-on B by itself causes no problems
Add-on C by itself causes no problems

Add-ons A + B cause the missing objects problem
Add-ons A + C cause the missing objects problem
Add-ons B + C cause the missing objects problem
Add-ons A + B + C cause the missing objects problem

People are running various add-ons, all of which use Simconnect to introduce objects into the sim and all end up with the same result of missing airport buildings and traffic. This appears to be reproducible.

1 Like

Happened to me at:

FlyTampa - KBOS Boston
Drzewiecki Design - RJAA Tokyo Narita
Samscene3D - RJFF Fukuoka

Same AIG and GSX settings (object densities), but other payware airports are fine. Very hard to know what really cause the issue.

I wonder whether there is an option, or is it possible to manually increase the object limit with SimConnect files?

Without consistent reproduction with a specific scenario that can be redone by the Dev Team, it may not be able to investigate further. I’m just pointing out this is how Feedback in other defect reporting was moved to Bug Logged.

Ok, the Dev Team wants consistent scenarios, so how about we use this template below so that others can try to reproduce the problem as well. I’m willing to test what I can within 1-2 hours flight time, provided that I have the appropriate addons. I’ll use my KORD-KOMA flight as an example.

Aircraft: Fenix A320
Departure Airport: FSDreamTeam KORD
Departure Gate: E6
Weather: Live
Time of Departure: 09:30 LT
Arrival Airport: VericalSim KOMA
GSX (y/n): Y
GSX Extra Ground Clutter (y/n): Y
GSX Passenger Timing: Dense
GSX Functions Used: Boarding, Ground Service, Baggage, Pushback
AI Traffic (y/n): Y
AI Traffic Program: AIGTC
AI Traffic Density: 90%

I know it sounds like a lot, but this should be able to help anyone who wants to try and recreate a scenario. If there is other important information to know, please feel free to include it.

You probably don’t even need to fly route completely. Just use the move function and move the aircraft to the TOD. And I wouldn’t test it with an add-on aircraft either. That’s not necessary.

I had the same issue flying into LOWI (ORBX). Frame rates dropped to 1.

I’ve been testing this by flying from bigger airports to other bigger airports as well as smaller to larger. In most cases I haven’t seen this issue happen going from smaller to larger, but if I go from one large airport to another it’s guaranteed to happen.

Reduced ground clutter in GSX and reduced settings in AIG TC. It still happens every time. If it is indeed a SimObject limit that’s been added, I would hope the devs are aware of the change they made, and can give us an option to select it off, or do a better job unloading certain objects previously loaded.

The game basially doesn’t work if you want to fly jets between big hubs with AI traffic active.

I don’t have any fps issues on final approach or int he vicinity of the arrival airport either. Everything seems to run very well through each phase of the flight.

Specific route to try? Aircraft, airports, GSX/AI Traffic settings? More specifically, which airports did you fly to with no frame rate drops on arrival while this issue was happening? I’m curious to try that out.

I’ve done KMIA to KORD, EDDM to LTAI, KATL to KJFK, RKSI to ZBAA, KDFW to KLAX. Fenix for some PMDG 737 for others.

Had GSX on reduced clutter mode, had AIG set to 70%. Disabled services in AIG TC like Kai said.

Some of the airports I flew to were linked using addon linker, but others were either MSFS default airports or were addons I had in the default community folder.

Had another one today:

FlyTampa CYYZ (Gate D38) - FSimStudios CYHZ
Time of departure 1225z
Live weather (which was quite heavy cloud cover in Toronto and along the rest of the route)
AIG Traffic at 100%
Fenix A320
GSX enabled but with extra ground clutter disabled.
I had AI aircraft when I first loaded it up but noticed by the time I was taking off ATC was talking to invisible AI aircraft. When I got to CYHZ the buildings were gone, performance tanked etc.

Honestly if the dev/testing team grabbed a few of these scenarios that are being posted here and flew them they could probably replicate the issue instead of us having to keep spending our time flying failing flights to prove the issue exists. I’d fly the ORD-OMA flight noted above just to contribute but I don’t have the addon scenery for KOMA.

I just tried your scenario with the same details as what you provided, but I got mixed results as even though the scenery loaded when I arrived, I had horrible performance. I have an i7-12700, RTX 2070 Super (8GB), and 32GB of RAM, so I’m not entirely sure what’s going on here with an airport like Halifax. Have you noticed poor performance at CYHZ with a fresh sim reload? What GPU do you have?

Below is a screenshot showing the VRAM usage.

Do you have any other short flights you could provide details for that cause this problem?

I agree, there are several scenarios listed in this thread, and more on another thread on another forum with more anecdotal evidence that people have had issues with. There have been 3PD developers indicate that it’s an object limit with simconnect that started showing up after SU10. This should at least provide an area of code to examine.

2 Likes

Can observe it too, most obviously at EDDK (from Aerosoft).
When arriving (doesnt matter if the flighttime was short or long) haavy stutters, low framerate, no smooth aprroach possible.
When loading a flight to depart from EDDK, everything runs smooth and fine.