Asobo 787 is downloading a previous version, rendering it unflyable


Just tested this again after restarting my sim. I did get 1.49 now and previously had 1.52. I am going to split this portion into a new bug report.

The bug: if you are on a version higher than 0.1.49, if attempting to re-download your aircraft, it will revert to version 0.1.49 which then has the fuel pump issues causing you to not have the ability to start the aircraft. DO NOT DELETE YOUR 787 if you have a version higher than 0.1.49. You can check your version in content manager.

This bug has been escalated with the CM’s - thank you for your reports. Please also submit them to Zendesk so that they can be collated.

It is, I had 0.1.54 which was working great, wanted to update to 56 but got 49 instead, and the fuel pumps didn’t start. Now why is it taking so long to send out the correct version of the 787 is a mystery to me.


I am 52 now and I spent at least 3 years with tweaking and optimizing flight simulators; fighting for every single fps or finding the right livery for my aircraft, going deep into the the mystery-coding of the FSX or X-Plane, 3rd party like PMDG, Aerosoft…so I am not too surprised. I know the simmer-scene quite well.
Nevertheless, we have month 8! after release…and I think it is now time to make the aircrafts functional.

@Angernerve: than you are very lucky. I did the same and always received the 49-version. I did the hard way and deleted the folder via the Explorer or I used the content manager, no difference.


Hmm, I don’t understand either. I tried that multiple times but the sim always downloads v0.1.49. Someone with v0.1.56 even backed up his file, deleted the 787, and the 787 file redownloaded was v0.1.49.

1 Like

It’s not folder related. I’ve tried it from a fresh install with an empty folder. The problem is still there. This is clearly a bug. I have 500 hours on the 78X. It worked fine until this last patch.

I’ve escalated this issue with the CM’s - thanks for the reports.


Thank you. I’m angrily flying the A330 right now. I HATE this thing. Give me my 78X back!


How do you do this?
Is there a way to update manually? I only see updates in the loading screen, so when there are big ones like the new sceneries or the monthly system updates. Except the hotfix from last week, I have never seen an update out of the row.
How do you update from 1.54 to 1.56? And where?

This explains why my fuel pumps were working while some people had issues with them. I have 1.56.

Voted, hope they can fix it soon.

1 Like

Right now, you can’t.
That is what he is saying, he had .54, he wanted .56, but he didn’t get .56, he got .49
The MS Store is, as you know, sending the wrong version.
Until that is corrected, no-one can.
Hopefully, having the moderator escalate the issue will help.


Same here but flying the 747 not bad but really want my 787 back.


I fly in VR, and the geometry of the 320 VC (so 330 VC too) are completely messed up. The 787 on the other hand : geometry on spot! And it’s much more immersive!

Does anybody know, how the new / old version exchange could be communicated? Is it just trial-and-error or do you expect a notification via Asobo´s website or as a part of an update?
I hope that one of you crazy guys is checking this 25 times / hour and will tell us…:wink:


Who knows if they’ll tell us, but I’ll be checking after every flight in my F15 and A330. As of this AM, it’s still sending out 1.49. I’m testing by deleting it from the Content Manager and re-downloading.

1 Like

My zendesk request got a response and says “solved”, but I can’t test this week-end

Mine too. I believe it is like that when they have seen and recorded the bug. Not that they fixed. I could be wrong though.

1 Like

I’m firing up my sim now…let’s see. I’ll check back in about 6 min.

It’s not fixed. 1.49 is still what’s being sent out. Ugh…

Yes, it’s true. The B787 performed very well and was stable. Since the update, big problem with the flaps … Impossible to arrive on a track at the right speed. Worse, the plane falls suddenly before touching the runway, which systematically damages the landing gear. Can we go back to the previous version? And how ? Thank you in advance

The previous version is a brick. It doesn’t work at all. Flaps will be the least of your worries as you can’t get fuel to the engines to move it. I just want a plane that flies. I can work with the rest.