[Asobo NXCub] Idle RPM too high etc

Please tag your post with #pc and/or #xbox.

Are you on Steam or Microsoft Store version?

Are you using Developer Mode or made changes in it?

Brief description of the issue:
Idle RPM is 1100+, way too high

Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered:

  • Load NX Cub
  • Start engine, note RPM
  • Try taxiing without using the brakes

PC specs and/or peripheral set up of relevant:

Build Version # when you first started experiencing this issue:

  • Idle RPM is almost 1200, which is almost twice as much as usual. Result: Plane is accelerating by itself when taxiing and needs braking, full flaps final approaches can be (almost) flown at idle RPM, very difficult to slow the plane down on approach. and getting close stall speed before touchdown.

  • Alternate air is pulled when loading the plane. Cosmetic bug though, because Alt Air has no effect on instruments anyway.

  • Prop is turning in the wrong direction

There is much more broken in the NXCub:

  1. the altimeter does not change when the outer knob is turned.
  2. The static air thing you mentioned is coupled to the carb-heat switch inversed. Turn on carb heat and the (cosmetic) alt air goes off.
  3. The landing light switch does not react to HC Alpha switch input. Cosmetic as well, the lights are on visually but the cockpit button does not flip. When doing it in the cockpit it works. The same bug exists in the older Asobo X Cub btw.
  4. RPM lever is erratic at best. It’s far too strong and when on ground I can pull it all the way back and up again with zero RPM change. Only when in air there seems to be a bit of a change.