ATC button won't work (Window not opening)

Hello everyone, I’m trying to open the ATC window, but when I click over the button it doesn’t open, how do I fix this problem?

One thing… When I’m using my A320 I’ve tried to activate the NAV on the top panel, but those buttons are inoperative

1 Like

click on the gear icon on top (the right most in that ribbon) and there should be an option to reset the widgets. hopefully that helps


It worked!


Thx so much, I’ve tried everything to fix this problem, and with your orientation its working again.

I really appreciate your message helping me.


1 Like

No problem! you can do the same again if the other widgets “disappear.”


Its very handy to know when your resizing the game window a lot things tend to get “lost”! :slight_smile:

1 Like

Thats true Tobyz, it’s always good when you help someone, right?

It looks pretty simple, but I had no idea about try to default the toolbar, it worked like a charm.

1 Like

my button wont work its geryed out and will not resey. anyideas?


does it do this?

if so it happens to me too and its really annoying.

1 Like

did u fix it?

Yes, check the previous image posted by Luke, do the same and it will be fixed.

oh I didn’t fix it

Same here - ATC option is grayed out, the same as the pic posted from @LukeB139247. Resetting panels doesnt do the trick. I’ve also tried changing the assistance options to “all assists”, “true to life”, selecting the “atc open at start” option but nothing seems to work.

I figured that pressing 1 / 2 / 3 etc responds to ATC requests, but the window is not visible…


Edit - I also don’t see the “tower” ATC icon on the toolbar either so it’s a slightly different issue to the one the OP raised.

1 Like

Thanks for the help ill try using the numbers, I wonder what is causing this.

@LukeB139247 I’ve managed to fix it! I had exactly the same issue as you so try the following ( i did change a few things in a short amount of time, but I think i remember the order correctly…)

  • go to assist menu and select “Assist All”
  • Hit save and apply
  • Do a flight for 3-4 mins
  • go back to assist and change it to the levels that you want

This worked for me


Im doing a flight right now but i will try after, thank you so much for the help!

THANK YOU SO MUCH!!! I just tried it and its working!!