ATC clearance button cold and dark start (FBW A32nx)

Hi guys,

Brief description of the issue:
Cant get clerance from ATC upon cold and dark start to work.

I have done the flightplan before in SimBrief and then load it in to MCDU, everything works OK there but the ATC clearence button wont work even if its displayed in the list of ATC options. AL interference is off.

Read that it helps to download Navigraph Navdata center and it did solve the problem for two flights, now i cant get clearence again.

Tried to change the ATC frequency manually but same problem, ATC clearance button will not work.

Please tag your post with #pc and/or #xbox.
PC

Are you on Steam or Microsoft Store version?
Steam

Are you using Developer Mode or made changes in it?
Stable & dev. same problem

Both FBW and FS up to date.

Hi @UrbanArtist4291, and welcome to the forums!

I assume you’re using the FlyByWire A32nx mod given the mention of simbrief import?

As far as I’m aware, to use the default ATC with FBW, the flight plan needs to be loaded into the world map planner before starting the flight. I don’t think just loading the plan into the MCDU will update the default (empty) plan ATC is looking at, but I may be wrong…

(Also, I’ve moved your topic to the #third-party-addon-discussion:aircraft category which is more appropriate, and amended the title of your topic to reference that you are talking about the FBW aircraft to make it easier for others to find your topic and add to the discussion)

I have the same issue. In the past, you could load a flight plan in the mcdu and get ATC clearence.

If you have the options set in the MCDU, did you also import it into the flypad?

It is not necessary to start the flight plan with the world map planner to receive later the IFR request at the ATC after the Simbrief import.

For this you have to make sure that you have set the option “Sync MSFS Flight Plan” to “save” in the EFB settings first.
Then you can import your flight plan from Simbrief into the EFB (via the Dashboard) and then the flight plan will be uploaded in 2 stages in the MDCU.

  • Via [MCDU MENU] → [ATSU] → [AOC MENU] → [INIT / PRESS] → [INIT DATA REQ].
  • And then on the [INIT A] page by pressing the LSK2R for [INIT REQUEST]

Then you can request the IFR clearance from the ATC

1 Like

Hi and thanks @LongHaulSky, great community.

Yes, im flying with FBW mod.

If i load & save from SimBrief to default flight planner the flight plans shows and ready in MCDU but the HDG on AP will not follow the flight plan at all?

@TheSevenflyer @Simson166

As for the flypad/EFB it seems it wont connect with my account (even if MCDU connects):

Therefore i cant access the “save” settings in EFB.

As you can see in the picture “TUNE LANDVETTER CLEARANCE” shows but when i press the button it jumps to the right frequency but immediately jumps back to default.

Flying with FBW mod is new to me, i´ve been flying the default A320 before, been using FBW about a month and done several working flights before.

Other option is to put flight plan manually in MCDU but i would like this to work or find a easier way.

Thanks for the answers all

First, with the FBW, do not use the default MSFS flight planner.
In the flight pad, under settings, ATSU/AOC enter your Pilot ID #.
That can be obtained from the “Dispatch Options” page of Simbrief.
While in the flypad settings, under Sim Options, put SyncMSFS flight Plan to save
Here is a link to the guide that explains how to load the simbrief plan into the MCDU
https://docs.flybywiresim.com/fbw-a32nx/feature-guides/simbrief/?h=simbrief#flight-planning

The FBW actually has a ton of great documention available:

https://docs.flybywiresim.com/pilots-corner/beginner-guide/overview/

Start with the beginners guide. It’ll show you how to set up the aircraft, including how to import Simbrief flightplans and enable the default ATC.

https://docs.flybywiresim.com/fbw-a32nx/feature-guides/flyPad/throttle-calibration/

Also make sure to calibrate your throttles on the efb.

Hi, set radio communication(ATC) to off (see picture), you can turn it back during the flight.
You can also try to depart from another airport to see if that will work. :slightly_smiling_face:

I did set the EFB option “Sync MSFS Flight Plan” to “save”. But still, MSFS shows me CLRC Dlvy Freq but does not allow to get IFR CLRC. What am I missing. I am using the latest DEVELMT version

Same here. Default msfs atc : can not ask clearance for an ifr flight plan imported from simbrief.
Using latest experimental version from flybywire