ATC clearance for non worldmap flight plans not available since SU6

Are you on Steam or Microsoft Store version?
Are you using Developer Mode or made changes in it?
Brief description of the issue:
Since SU6 I’m no longer able to request an IFR clearance for “non worldmap” flight plans. Before the update it worked fine.
Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered:
Just select the FWB A32NX or the Aersoft CRJ and start a flight at any gate at any airport without making a flight plan in the world map. Enter the flightplan manually in the MCDU/FMS or import it from Simbrief. Once you setup everything try to get a flight plan clearance from ATC. The option is missing only requests for North/South/… departures are possible.
Build Version # when you first started experiencing this issue: (SU6)

Anyone else having this issue since the latest update? I’m also using Navigraph navdata if this should be relevant.

I have experienced the same issue with FBW A320 dev version and SU6. I have tried both importing the Simbreif plan and entering my own in the MCSU … but no offer to get clearance from ATC.

Same issue

Well ok at least I’m not allone :confused:

I can confirm that when I manually entered a flight plan into the garmin unit of a C172 and then contacted ATC I was not offered the option of obtaining an IFR clearance.

1 Like

Same here only ifr clearance when filing flight plan in World map

One way I have got this to work is to enter the flight plan as soon as the flight deck is powered then to contact ATC immediately for clearance before doing anything else.

For the FBW A320, if syncing with simbrief doesn’t allow for IFR clearance first time around, then restarting the flight and then powering on the aircraft and immediately retrieving the flight plan and contacting ATC gives me the option to achieve an IFR clearance.

However, any subsequent changes to the flight plan or trying to create a flight plan a few minutes after the flight has started, or creating a new flight plan no longer gives the option to achieve an IFR clearance. This also seems to apply for trying to file an IFR flightplan when airbourne. I haven’t managed to achieve that as yet.


Ok that sounds interesting and I will check that on my next flight but anyway this is not a proper solution. I still hope Asobo will fix this with SU7 or maybe also earlier with a hotfix.

1 Like

Ok I now had the time to try your way (multiple times) but still no chance to get the clearance. I just hope it will be fixed with SU7.

1 Like

Out of interest, @M4V3R1CKPRO, I am using the dev version of FBW and not the experimental version.

I believe the experimental version is not syncing the flight plan back to the built in sim flight planner and that may account for not getting IFR clearance, if that makes sense. If the CRJ is also not syncing the flight plan with the game’s flight planner then that could also explain the lack of IFR clearance there.

I believe some changes were made to the ingame flight planner with SU6 as well, but the exact details of what those changes were elude me and I haven’t read any detailed description anywhere, that I can remember.


Not fixed in World Update 7 from what I can see. Bummer

But I think I found a workaround (at least using FBW320).

1- Go to the electronic fly pad setting, under “Sim Options”, change Sync MSFS Flight Plan to “Save” (is “Load Only” by default). Save this new setting
2- Go back to the main menu. Select your departing airport and your gate number (if you want to start cold & dark). Nothing else
3- Click on “Fly”, start the A320 as you would normally do (i.e. Bat 1, Bat2, External power)
4- Go to AI ATC window, tune to the airport clearance frequency: No option for IFR clearance delivery (yet!)
5- Go to the MCDU, Init , Select INIT REQUEST*. The flight plan gets loaded into the MCDU and…
6- Check again the AI ATC window (tuned to Clearance). You now have the option to request IFR clearance

1 Like

@Rascal650 A massive thank you!

I recently moved over to the FBW experimental version and was not getting the ability to request IFR clearance with ATC for simbrief loaded flight plans.

I now can :smiley:

I think the first thing on your list was the ‘key’ step:
Go to the electronic fly pad setting, under “Sim Options”, change Sync MSFS Flight Plan to “Save” (is “Load Only” by default)

1 Like

Yes it’s working for the FBW. But I guess for the CRJ we need to wait or maybe contact Aerosoft about that issue. Probably there was a change in SU6 which Asobo will not revert and all aircraft need some tweaking.

This change was indeed introduced in SU6 but I’m not sure if Asobo is going to fix it soon.

I believe the problem is that if you don’t specify a destination airport, Asobo’s flight planner does not see the flight as IFR and therefore the AI ATC won’t give you the option to get clearance.

If you specify a destination airport in the default flight planner, you have the option to set it as IFR High Altitude but then the problem is that you end up with 2 flight plans. The first one from Asobo’s (which seems to be used by the AI ATC). The other one from Simbrief which gets loaded into FBW’s MCDU. It’s really hard to keep them in sync. Especially if you make any changes from MCDU’s once in the cockpit.

I believe that the FBW’s EFP option to overwrite the default flight plan is a good idea and allows us to have a single flight plan.

My problem now is that the AI ATC ATIS is wrong and does not match the ATIS I’m getting in the MCDU. So when I choose a departure / arrival based on the FBW ATIS, I very often have to change it when I call ATC. That’s frustrating. There is another thread about this problem: