ATC does not match airport

I have been flying around Florida for the last few days. I have landed at many airports, all land based airports. Right after I acknowlege switching to Ground control ATC does not connect with ground and I have to find my own way to a parking space. Later when I am ready to depart when I turn on ATC the runways offered are not runways available at that airport and they are always water runways. I have to just leave on my own without ATC and later when I land again and shut down the airplane I notice in the logbook that the sim did not give me credit for the takeoff at the airport I last left. Several months ago I had this same problem at a lot of airports in the Northwest of the US. Is there a solution for this? Is anyone else having this experience? This is really a big problem at large airports with lots of runways and taxiways.

Just for a laugh why not try editing one of the airport in Airport Design Editor and check whether the airport in question actually have ground ATC, if not you could always add the ATC you need recompile the airport and fly! If you wish to add ATIS to the airport the name of the airport is just the four letter airport prefix, ie for London Heathrow, ATIS name would be EGLL plus the frequency.
Don’t forget if it does not work or you change your mind, you can just delete the edited airport from the community folder as ADE never edits the original only a copy of the airport, hope this helps.

Can you give an example of one of these airports so we can try and see if we can duplicate this?

This evening while I am flying around I will make a list of airports with this problem. I find it hard to believe that I am the only one seeing this issue. I’m talking about several maybe most of the airports from Ft Myers all the way out to Key West. Pretty much any of them.

Personal Comments and Observations

At the most, I’ve seen untowered fields where they clearly should have a tower frequency, but in general - the underlying AIRAC data is what defines radio frequencies for facilities.

It’s worth noting that many untowered facilities will rely on the nearest towered or Approach/Departure frequency for things such as ATIS and Clearance Delivery. That’s what you may see in the ATC menu. I fly out of KBID (Block Island, RI) a lot. There is a local ATIS/ASOS, but for IFR, I have to talk to Providence Clearance Delivery over on the mainland when departing.

Currently touring New Zealand and I’ve noticed a couple of ATC oddities but have put them down to referring to nearby airports - this has usually happened at very small airports where I’ve not been expecting any ATC.

But earlier today I flew from Takaka (NZTK) to Wellington (NZWN) and on starting the radios the menu offered me Hobart, which isn’t even in the same country!

I do enjoy these little foibles!

For the folks experiencing mismatches,are you on Azure Text-To-Speech or Offline ATC? Because I’m on Offline (it never drops and saves on my Data consumption) and I’m not hearing/seeing these errors.

Azure for me.

I need a quick lesson in Azure and Offline ATC. I don’t believe I have either one. When I post some airports to check it would be great if someone would give it a go. I don’t think you should take off from those airports initially. I think you need to fly in from anywhere else, park and shut down the plane, wait a few minutes then fire it back up and turn on the ATC and see what you get.

You have one or the other. ATC voices are set to either Azure Online or Offline using local Windows Voice files based on your localization.

Thanks for the info. I’ve already shut my sim down for the night but I will look at these settings tomorrow.
I think I need someone who is using the online text to speech and the in sim ATC to get the results I am getting. Tonight I could not get landing clearance on the first 2 airports I tried. I landed anyway but then could not get taxi clearance to park. So I just parked where there were other airplanes. Turned off the engine and waited about 5 minutes. Restarted the plane and the correct ATC came up. So I moved on to a couple of other airports. I found 3 that were giving me the error. I landed at KFXE, parked and shut the plane down, waited 5 minutes started it up and the ATC said I was at KBIC with 2 water runways. I took off and went to KSUA, did the routine and when I started up ATC said I was at 1FL FT Pierce with 2 water runways about 20 miles away. Then I flew to KFPR landed, parked and shut down. When I started back up ATC again said I was at 1FL now about 5 miles away. So if anyone is using the generic MSFS ATC please give these airports a try and see if you get what I get.

I changed ATC text to speach to OffLine. Last night I was going to test it out but after 4 tries at getting a flight to start (disk 5 has been surprise removed) I gave up and decided to move my Community folder. I put the F6F Hellcat as the only thing in the community folder so I could fly it. The sim booted up and I was able to start a flight. I landed at 3 or 4 of those airports I was having trouble at and did not have any problems with ATC. So, hopefully this problem is solved. If I can get in 2 or 3 hours of flight time tonight without ATC issues it will be good.

Last night got about an hour and a half flight time Made 5 landings between Ft Lauderdale Executive and two small airports past Marathon KMTH (don’t remember what they were). The only airport I stopped at that the ATC said I was at a different airport was Marathon. When I got ready to leave there, ATC had me at 42FL which is a seaport with 2 water runways. It was 35 Miles away from where I actually was. What I find strange is that these other airports are always seaports with 2 runways and they are not necessarily near by. And I seem to be the only one experiencing this. I have the ATC set to offline.

1 Like

I wonder if your cloud settings save is somehow corrupted.
If you aren’t too concerned with logbook being saved you could try this.

Thanks for the information but I’m not ready to delete the logbook right now. This phenomenon only happens with airports near water and it doesn’t happen every time so for now I will put up with it. If there was a way to save the logbook data and plug it back in that might work. But it’s probably the data that’s bad. It would be great if you could save just the totals and have your new logbook add to them.

1 Like