Atlanta area crashes

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

No. Production version, Premium Deluxe

Brief description of the issue:

Something is corrupted? with the Atlanta area. I cannot start a flight from KPDK (my home airport!) or KATL. The load screen gets about 50% through, the screen freezes, and my headphones start screeching loudly. I have to power down with the PSU switch to get the PC to shut down. The same thing happens if I start my flight somewhere else, and approach the Atlanta area. About the time I start preparing for my approach into KPDK, the sim freezes and headphones screech.

I have tried reinstalling FS, running in safe mode, removing all 3P add-ons… nothing seems to let me fly through the ATL area.

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

Attempt to create any flight that starts at KDPK or KATL. Does it with the Beechcraft Baron with all 3P add-ons removed, and even in safe mode. Been like this for several months now but I just put 2-and-2 together that it always happens with the Atlanta area.

PC specs and/or peripheral set up if relevant:

i7 10700k (stock clock timing), 3090FE, 32gb ram

Build Version # when you first started experiencing this issue:

Definitely reproducible with but this has been going on a few months.

:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

No issues here. Took off 21L in the default baron with FLT PLN to Asheville. Climbed to 8000 and stopped test at about 15 miles from airport. Ran sim at 4k Ultra, 250 LOD.

1 Like

User-mode applications such as MSFS generally cannot cause a total system lockup unless there are deeper underlying issues with the system, hardware, drivers, etc. This would likely explain why the above user couldn’t reproduce the problem on his system.

1 Like

And that is a plausible theory, for sure.

But I can 100% reproduce it. Try to start a flight from KPDK or KATL = crash 100% of the time.

Try to fly into the greater ATL area = crash 100% of the time.

Flying out of Chicago area, Las Vegas area, or Los Angeles area (these are the other areas I fly regularly) and I can fly around for hours with no issues.

I only have MSFS, DCS, iRacing and Assetto Corsa, on my rig. And DCS/iRacing/AC I can play for hours on end with 0 crashes. But the instant I try to fly in MSFS into ATL… crash.

So maybe it’s some wonkiness causing some kind of weird driver conflict or something… but I mean, it’s 100% reproducible. So there’s something there… and I say that as a software engineer myself.

Hello @OmniGLH,

I am unable to reproduce this crash. Flying out of KATL and over the Atlanta area is working fine for me without any issues. I took the screenshots below about 30s ago.


1 Like

You need a Windows expert to debug your system. Something is definitely broken on your system.

Ok. I will wipe the HD that has FS2020 on it and reinstall it at some point in the future and see if a total refresh fixes it. Thanks anyways!

Ok some more information to add.

I removed the entire contents of the Official/OneStore folder. This forced the app to redownload everything. Took several hours.

From there, I was able to take off from KPDK and KATL! I thought I had it solved. Then I noticed, under content manager, that all the World Updates were not installed.

I installed them - and the crashes at KPDK returned. I wound up wiping everything again, starting over, and adding the world updates one by one.

As soon as I add World Update 2: USA - it crashes when in the ATL airspace. If I delete (even via the Content Manager) WU2 - I can then fly/takeoff/land in the ATL area.

So for whatever reason, on my PC… it no longer likes WU2. All the other WU’s seem fine.

What’s strange is I know I have flown with WU2 in the past. But it doesn’t like it now.

Try deleting just KATL instead of the entire world update. It’s a large airport and thus can be very taxing on computer resources.

You can delete or add single airports using the content manager package view (button near the top center). Even better, you can copy (backup) the actual package folder using Windows Explorer before deleting it in the sim (to copy it back afterwards, if deleting it didn’t change anything).