Australia - Points of Interest - cannot download

Are you on Steam or Microsoft Store version? Microsoft Store

Are you using Developer Mode or made changes in it? No

Brief description of the issue: Cannot fly Sydney Discovery flight. It sends me to Market Place to donwload “AUSTRALIA - POINTS OF INTEREST”, but it cannot be downloaded. Says: “unavailable”.

Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered: I’ve upgraded the sim to, and updated all World Updates. Now, try and start Discovery Flight, Sydney. It shows a dialog stating:
"The activity you have selected requires the following content to run
Go to the Marketplace to buy and download them
When I press the button to go to the Marketplace, the content is “unavailable”, and therefore cannot be downloaded.

PC specs and/or peripheral set up of relevant: Ryzen 5800x, Windows 11, Version 10.0.22000 Build 22000.

Build Version # when you first started experiencing this issue: Experienced today, a few hours after the latest world update became available. I gave it half a day and retried, but the problem persists.

Have you tried going to the marketplace first, look at the FREE section. this should show you the Update VII to buy & download.

After that, then go back to the discovery flights

1 Like

WU7 is NOT in my Marketplace either.

The rest of the updating went very quickly but I can’t get the Australia content…

1 Like

You need to go to the MSStore.
At the bottom left of the store page is your library icon
In there at the top is Updates.
Click that

I checked the MSStore > Library to get the sim update. That does nothing for Marketplace content.

Was there updates there to install?
If so, after you updated, did the item appear in the Marketplace?

I had exactly the same problem. The world update is available in the STORE and not in the marketplace.

You have to download it from the store first.
Then it should appear in the marketplace.

I ran into same issue trying to fly in Sydney, got the message "Item(s) required: “Australia - Points of interest”, which is misleading, as the complete World update was missing.
I went to the Marketplace and downloaded the “World update VII: Australia” and issue was resolved.
So the confusing part was, not the item by itself was missing, but the whole World update VII with Australia.

So after it’s installed, check out Shellharbour airport and you’ll see the 747 !

I did confirm in the sim Marketplace, that Australia World Update is not installed, while all other past World Updates got updated. But in the Microsoft Store, I don’t see any more update. I searched for “Australia”, but nothing.

Start with Microsoft Store, then Content Manager and finish at the Market. Three piles of downloads.

OK. I was able to download it just now.
There was another small, automatic update in the sim for an updater, and then, when I searched in the Marketplace for “australia”, I found the WORLD UPDATE VII: AUSTRALIA, and was able to start downloading it. I don’t remember this was the case with previous world updates, but anyways, the issue is resolved for me.

1 Like

Then go to the content manager.
There will be several updates there to install as well!

I’d done that on the first day of the WU7. The only remaining thing was WU Australia.

1 Like