Autopilot altitude changes

Coming from FSX here…when you’re flying along on autopilot with ALT hold selected (in FSX)…if you change the set flight level in the autopilot then the aircraft will climb / descend to the new ALT you’ve set at the vertical speed showing in the autopilot.

In this game, it doesn’t seem to have any effect. I’ve also found that (in the Bonanza at least) if you switch to vertical speed hold mode and then click the UP button to increase vertical speed by 100fpm…the autopilot will switch straight back to ALT hold and not go anywhere.

Is this a bug or have autopilots changed since 2006?

1 Like

Same issues here, and not only in the Bonanza, unfortunately ! Also with the autothrust, bugging the same way.

According to some internet articles, a looooooot of complaints about the inaccuracy of autopilot and fmc had been sent. Just hope we’d have a major navigation tools update soon (although they already have a lot of work fixing the download and install issues… I think it’s not for tomorrow…)

Same here… in the 172, to get to your altitude setted, you have to dial in the altitude, and then the VS trigger up or else thr airplane does not answer to the autopilot commands… it’s like your second kidney… some people think it’s unuseful little extra, but feels the pain when you don’t have it… :wink:

I was also struggling with this, but I’ve managed to work it out in the Diamond DA62, after referencing the real life DA62 manual PDF.

Procedure that works for me:

  1. Set AP to ON
  2. Increase/Decrease target altitude as required, using the ALT knob.
  3. Select the AP ALT mode to ON. Nothing happens at this point.
  4. Select the AP VS mode to ON. Still nothing happening.
  5. Increase/Decrease Vertical Speed using the “NOSE UP” / “NOSE DN” buttons on the MFD based on how fast you want to change altitude and also based on whether your target altitude is above or below current altitude.
  6. Viola! The plane shoudl start ascending/descending to target altitude. About 300 feet away from target altitude the AP should auto-switch back from “VS” to “ALT” mode and should maintain your selected altitude.

Again, this works for me in the Diamond DA62 - I have not tried this in any other aircraft.

Good luck.


This seems to work the same way in the other air crafts

Nope, not in the Bonanza.

AP ALT set to ON. Nothing happening.
Set Alt to xxxx ft. Still nothing happens.
Click AP VS to switch on, still nothing happens.
Click the button to increase vertical speed…and the AP mode goes straight back to ALT.

I didn’t try the Bonanza yet but i think i know the issue you describe. When witching to VS mode after setting the climb/descend rate, the value gets deleted and it switches right back to ALT.

Follow the procedure from @McDumpling2000, there you first set your ALT, Switch to VS, select climb rate and then activate VS.

Maybe this helps

We should all submit these observations as bugs to the zendesk.

Discussing it here is great reading, but it wont get them fixed.

The more reports they get, the more chance that they’ll fix it.

The devs rarely read these forums.

Submit to

1 Like

No, no. As I’ve listed there, I click AP VS mode on, then I click one of the buttons to increase climb rate and the AP switches back to ALT hold mode.

So…the devs don’t read the ‘feedback’ forum? Why did they create it then?

The devs have processes to follow.

The entry point is the bug submission via the Zendesk where issues are verified, categorized and prioritized.

Forum moderators do an excellent job of identifying hot topics and passing them up, but we can’t expect the devs to spend time wading through 100’s of posts looking for issues when their intray is already full of them (via the Zendesk).

That’s not to say that they don’t drop in here and there, but we shouldn’t expect a guaranteed response to an issue just because we raised it here.

It’s great to be discussing issues here and we all enjoy the community spirit, but it’s important to also submit these concerns formally as it has a better chance of getting their attention and to lead to a solution.


1 Like

I totally agree with that!

Please, someone who really knows the planes and the autopilots should file a report at zendesk.
I for myself, i cannot judge if this is correct behavior or not, so i wouldn’t complain about that. It works like described above, had to figure this out myself by trial and error :slight_smile:

I don’t know if this is how you have to trigger asc/desc in a real auto pilot. I do not fly motorized in RL :smiley:

@SwoopGB - hmm… that’s really weird. I just tested this in the Bonanza and on my system it works fine. Not saying that there is no problem, just that I can’t reproduce it on my system.

In this shot altitude is set to 4000ft, AP VS is ON and VS set to 1000fpm. The plane is auto-climbing from about 1500ft towards 4000ft:

Here the plane has reached 4000ft, and AP has auto switched from VS to ALT mode and levelled off:

And I’m really not trying to insinuate that the AP on your system isn’t misbehaving. It’s very much possible that on some systems it works fine and on some it doesn’t, for whatever reason. Just thought I’d share the screenshots in hope that you find some setting, or something, that helps you resolve it and get back to enjoying the game.

Hope it helps. Otherwise, let’s hope the devs fix it very soon!

Something very odd going on here cos when I try to follow your steps different things happen:

  1. AP Set to on - ok AP light is on.
  2. Set target ALT to 6000ft - ok
  3. AP ALT set to on - ok, AP ALT light is on.
  4. AP VS set to on - AP VS light on, AP ALT light goes out.
  5. Set VS speed up by 100ft - ok, plane starts a 100fpm climb but target alt has been set to current alt and the plane will never stop climbing. Setting the target alt back to what I wanted it at in the first place has no effect, plane will climb through target alt and keep climbing.