Autopilot not following flight plan

Does it just fly straight ahead? Runway heading? Other?

When I engage the autopilot, nothing happens and the plane continues on the course that is just then! I have tried via manual steering to steer towards the specified course in the flight plan but without positive results, ie the plane continues its own path (does not follow the flight plan)!

With the AP button pressed/lit, cycle the NAV button OFF then ON again. It should turn to the direction the Magenta Arrow is pointing to in the Compass Rose on the Primary Flight Display screen.

you probably have the CDI source on Nav1 , plane will fly straight ahead.
you can see what CDI source you have selected inside the Compas on the left screen , Purple = GPS = flightplan , Green = Loc1 or Nav1 , Double green = Loc2 or Nav2 , you can select the source of Cdi by pressing the button at the bottom of the left screen where it say’s CDI.

b.t.w changing the CDI source will disengage the NAV on the autopilot , click it again to activate :slight_smile:

3 Likes

I have tried NAV button OFF then ON again but without results.
Note the conditions regarding autopilot etc. are the same in case 1 as 2!

Many thanks for your help gentlemen but I unfortunately have to leave my PC now.

When you get back, it might be worth you posting some screenshots of your avionics. Zoom in to the relevant things if possible to make them easy to read.

There might be something obvious at work here that you aren’t describing correctly.

Hello,
I moved your post to the Instruments section and put the word Autopilot in your title so it’s better understood what this topic is about.

Thank you!

1 Like

I’m having the same issue with the beechcraft king air…

Have been for a while. It’s not hard to understand, it’s simply that the AP will not follow the flight plan… even when NAV is on…

Can you set a direct to waypoint? Maybe that kickstart the following of line?

Issue with flight plan

  • Aircraft/Autopilot doesn’t follow the Flight Plan. Solution: Open Windows 10 Control Panel > Region > Administrative Tab > Change System Locale… Uncheck: “Beta: Use Unicode UTF-8 for worldwide language support ” - Reboot the computer.

https://forums.flightsimulator.com/t/ils-landing-went-wrong/410273/49

IFR KVGT → KBUR

Issues with the AP not following a VOR course, but would follow the GPS. (VLOC vs GPS on the CDI)

Heading bug fine, too.

Might be a stupid question but when you set your flight plan in world map did you select a GPS flight plan ? If so I’m not sure that the auto pilot will follow the route.

Make a flight plan and set it up as ifr low or high Airways flight plan. Choose your cruising altitude set that in your altimeter and then arm nav mode once you take off turn the auto pilot on and that will follow the route of your flight plan. You have to make the altitude changes in the altimeter autopilot section as your going along to adjust altitude but then you can use vs mode to lower and higher your plane as you wish.

This helped me a lot!!!

@ TryingSquire06,

I too had the same problem too. Have you tried switching to Cessna Citation Longitude, set up a flight plan, you request pushback instead of the AI pilot, stop the pushback, then have the AI pilot takeover for the take-off by switching him on, and after take-off, turn him off and engage the FD (Flight Director) button, the VS (Vertical Speed) button, the VNAV (Vertical Navigation) button, the NAV (Navigation) button and then the AP (Automatic Pilot) button? The aircraft should now follow the flight plan you set up in World Map. I too had several failed flights before I stumbled on this. Hope it helps. Hope to see you in the air! :slight_smile:

PS - Also if you are approaching an airport and you are landing there, just hit the APP (Approach) button. Haven’t tried it out yet, but I will soon. Flying from London Heathrow (EGLL) to Frankfurt Am Main (EDDF) via flying over London, the Cliffs of Dover, Lille and Namur.

PPS - Apparently, if you hit the APP button, it disengages the NAV button. I am now approaching Frankfurt.

Same problem, and my solution was to quit the MSFS and restart it. It worked and was able to follow GPS.

I have the same issue with the 787, I have this issue every single flight I do after takeoff. Once in the air I basically have to correct the flight following manually until the aircraft finally catches the flight path. Its definitely a big bug that needs to be fixed. I use LNAV and the first turn it makes to catch the flight path never works, it banks so hard and will continue to turn unless you manually correct. But like I said once I correct it a few times it will catch and my flight is good after that.

This did the trick for me. Thank you

1 Like