Avoid file locking issue when using MSFS Addons Linker

I use the Addons Linker and its a great tool especially when it comes time to do an MFS update, however you can experience an issue with .json files being locked. I have examined this and found it to be caused by the developers deliberately changing the ownership of all files in the Community Folder that have been loaded at least once by running the sim. The “big” issue is that this means that even third party purchased addons have their file ownership changed (locked). This seems to be only an issue with .json files.

I have not found a way to regain ownership of these files, so the immediate answer is to never let MFS get to them in the first place. Therefore if you install third party addons and you can’t prevent them from being installed in the default CF, make sure you don’t run the sim.

Move the addon out to your Addons Linker CF first. Otherwise the only way to fix any addon that has had it’s ownership “locked” is to re-download it or at least unzip it again if you have kept the original .zip file.

1 Like

I’m using MSFS AddonsLinker too and don’t have ownership change, neither in Community folder nor in the folder where I put my addons.

There is no issue with any other location other than the default community folder. If you install an addon in the default folder and run the sim, the ownership of these files will be changed. This has no effect if you only run the files from there or if you copy the files to a folder of your choice before running the sim. The issue only appears if you have addons in the default folder and run the sim, from then on you will never be able to move them to another folder an run them in Addon Linker, you will get an error message “unable to read XXX.json file”

1 Like

@flightlevel300 Thank you for this valuable information. Now I understand why I loose ownership and unable to move any such add-ons. I had to resort to always delete them and recopy from the new location if needed.

Running MSFS Addons Linker as administrator is another solution

1 Like

@GAParadise Yes! I just installed it and it’s really a great add-on. Thank you.

Hi, I use Addons Linker as well. I realize this shows my total ignorance, but how could I tell that the .json file has been locked?

No worries Mark, just try editing it in a text editor. If the ownship is locked you won’t be able to edit it. Safest one is Notepad++ (https://notepad-plus-plus.org/).

Oh and for safety, if you can edit it, cancel and changes.

Also, from memory I think you would get an error message from Addons Linker saying it can’t edit (or access) the .json file. This is how you first know about it.

1 Like

That’s a good suggestion, I will give that a try. It would be a simpler solution.

I checked my Addon Linker setup and found that I have set to administrator therefore this did not solve the problem. Today I purchased Cologne/Bonn from Aerosoft and the installer places the install into the default Community folder (no path option was offered).

When I tried moving the folder to my AL community folder and checked I found the .json files were already locked, while they weren’t when they were still in the default folder. This has shown me that even without running the sim, the files get locked.

Just to clarify, when the files are in the default folder, you can access them with an editor, as soon as you move them and try to open them in the editor, they are locked.

I only want to have files installed in the AL community folder so I’m very discouraged to purchase third party software if this is going to happen.

The only supplier that I know at the moment that allows you to choose your install folder is Orbx who have always allowed this choice and set up a symbolic link in the same way that Addons Linker does.

I’m getting this message on the addons I previously put in the default community folder. I deleted them and reinstalled from the zip, yet I cannot activate them. Other new addons no problem.

strong text

I have recently heard from Bad_T, the Addons Linker developer and he suggests trying copying files out of the default CF to a new location rather than moving them. As the copied files do not get their properties modified/locked but if you move the files they are locked. I have not tried this yet but it makes sence. Don’t forget to delete the files in the CF when you are finished. You don’t want duplicates

I am having the same “cannot read the manifest” problem you describe but I find different circumstances with permissions and ownership that you describe.

I compare two manifest files (.json) one of which can be read by Addonslinker and thus there is a valid link in the Community Folder and another .json file which the linker says it cannot read.

Both .json files have the SAME owner and same permissions. The owner is the system administrator and ALL users have Full Control permissions. I have verified this similarity at the folder level and the file level.

I can find no reason the .json in question cannot be read - everything relevant to sharing, permissions, and ownership is identical to a .json file that is successfully read.

Ran MSFS_AddonsLinker with ProcMon active in order to track all system calls. I found that the Linker was using the incorrect Folder name for the source of my adds for SOME but not ALL of the mods. When Linker Queried / Opened with the correct Folder name (All Community Mods) it was able to add the link to Community folder.

However, much of the time Linker tried to open the correct file but was using an incorrect Folder (All Community Files) in which case it received the “cannot read…” message.

I manually deleted (ShiftDelete) all links in the community folder, ran Linker, unchecked everything in Linker and closed it. I then ran Linker a 2nd time and selected all the mods and Linker successfully created everything with no errors.

I think the problem occurred when I renamed the Mods folder and changed the mods folder name in Linker WHILE I still had some links, based on the original Mods folder name, in the Community folder.

Nice program and works well!