B key setting altimeter

Ok, I wonder if anyone else has this problem since the last update? I have the B key on my keyboard set to … set altimeter…
Before the last update, if I pressed it the altimeter would change the current barometric pressure and my current height would be displayed. (i’m sitting on the runway when I try this)
Now though, when I press the B key the altimeter winds down to the lowest setting possible and I get a negative altitude. Anyone else seeing this or is the problem my end?
Cheers folk
Mick

Potentially because your on the ground. Works fine for me

1 Like

No issues with B here.

1 Like

Works fine for me too. Even got it programmed into my Stream Deck.
Sounds like a corrupted file when updating - if you could find the relevant file and delete it, next game restart ought to reinstall the correct file. Sorry, though, have no idea which file it would be - anyone else?

No problems on my side . P.C. User. To adjust pressure by pressing “B” is a sort of short-cut to avoid turning the related knob when ATC tells you the actual pressure to set. You can check if the pressure you get by pressing “B” is the same (it must be) of the ATC ones. If yes then you are ok. Negative altitudes : I 've never encountered this problems but I had a chance to read some post in the forum where some reported this problem that could be a real bug on the airport data. If you notice this on all the airports then it could be a real problem (don’t know how to fix it).

No Problem so far.

Thanks for all the replies.
Happens at all airports and when I am in the air also. Press B and the altimeter unwinds.
Wondering if it’s something in the community folder. I’ll remove that and try again to eliminate that option.
Mick

First step is always to clear community folder. Also consider what external programs might be running that will have an effect (thru FSUIPC, SimConnect, etc).

1 Like

I would go into controls setting and double check that something else might be bound to B that is causing it as well.

Same thing here, even manually setting the baro according to ATC calls doesn’t fix it. I’m investigating but it so far affects every plane iv’e flown. Will report back if I find a fix.

Removed the community folder. problem still exists. Verified all core files through Steam. Still there. Checked all key bindings. No conflicts, only altimeter is bound to the B key. Interested to hear I’m not alone in this. Hope to hear from Manbear if he finds a solution.
Mick

Little test C172 G1000,

set clear weather and sit cold and dark. Do start engine CTRL+E and look for first what pressure you have on altimeter. I expect 1013HPa or 29.92 and then push B. What now? It’s not there only B key set but only altimeter pressure increase/decrease so look carefully about other commands. Sit on LZIB airport, altimeter can read about 440ft.

I think I have solved my problem. When checking keyboard inputs I noticed there are two settings for the altimeter. One in the radio section and one in the instruments section. Both were set to the B key. I have removed the radio setting and it now seems to work correctly.
Thank you for the help. Manbear64 I hope this helps you.

2 Likes

Sorry for the felay, but no news I’m afraid tried just about everything but the issue persists. I have managed to get the pilot side garmin to display the right altitude sometimes by setting the baro according to ATC, but it isn’t reliable st all. Hope someone finds a fix or we may have to wait for a patch. Be careful near the ground! I guess it’s good practice in a way but we need this fixed ASAP.

Just saw your post…going to try it now!

I am having the exact same problem but my B key was already only mapped to Instrument altimeter. I made sure it’s not mapped to anything else and no luck.

Sorry to hear that. Ensuring no multiple bindings solved it for me.
Hope you find a solution.

ManBear64, how did you get on with this problem?

Yep, fixed turn off the colisman radio altimeter key binding as you are probably not using radio nav anyway and the issue is fixed. Su11 obviously added the binding to existing altimeter settings

thank you, it worked