B787 Fuel Pumps Not Engaging

Hello there,

I ve been haviong issues with the 787 since the latest update. Was working fine before. Now the fuel pumps buttons doesnt want to be press and the Engine wont start.

I ve tried everything, even downloading a Freeware mod of another 787…same result. Engines wont turn on.

Anyone please HELP !!!


1 Like

I also have the same problem

1 Like

Glad to ear that…lol

I ve tried everything that I could think of…even re-install Steam and FS2020. Same thing

Just tried. Cold and dark and starting with the engines running.

Fuel pumps can be turned on and off without any problems.

I’m running a vanilla MSFS install.

I also have the same problem

Same issue here

The same issue, can’t use the plane now

The developers probably are not experiencing this on their systems so I get it keeps getting ignored update after update from what I see. Nice updates but still can’t fly the 787.

1 Like

The same for me. After 1.12.13 update.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.