Black screen loading freeze

Have same issue. Never got this issue before. Getting black screen after a while a small windows pops up with no info in it. Can only close it. Then it proceeds to “please press a key”. After pressing a key, black screen starts over again. It repeats forever…

Windows update and/or reboot fixed my issue

Blacvk screen form after 3 months of working perfectly. What a mess!!!

Same issue. At the black screen Task Manager show the following activity: about 4-5% CPU, 1500MB Memory, 0%Disk, 0% Network, 95%GPU, Very High Power Usage. I am on Insider Dev Channel with build 21318.100. Two builds ago everything worked fine. I have another PC with build 19042.804, not on Insider Program, everything work fine here. Have tried all suggestions on all forums, no luck. A third PC which is on Insider Beta Channel, build 19042.804 also has the black screen problem.

Hi @RevelrousFive36,
Please also report this on the feedback hub for insiders. MSFS is built to run on public Windows builds. I also use insider builds but I’ve not tried it on the current Beta Channel.

Yep, same here. Did nothing but installed my G2 yesterday, all worked well but now the sim won’t boot. It’s shows my pc is doing something with the flightsimulator process but it’s stuck in a black screen.

Solution: For some reason my Geforce Experience was not updating the driver (or I was on a beta driver). I manually downloaded the latest driver from the nvidia website and this fixed the black screen problem.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.


I’ve solved the same issue stopping using Sound Blaster SPDIF as audio output device. Using Sound Blaster (virtual) speaker fixed the problem.
FYI, I’ve used sysinternals Process Monitor to point out this (MSFS was looping on some registry section about audio)
Other workaround is to use -FastLaunch option, but no idea on any other side effects…
Unfortunately, I uninstalled MSFS, now I’m stuck with a server bandwidth of 2.5Mb/s. It will take years to re download the software


@Willfre4494 - good point with the Sysinternals Process Monitor.
I tired it, and with me it was similar: durching the BlackScreen MSFS was accessing the RollingCache and some kind of Sound.Init (?) space or routine.

For me the problem seem to be solved by applying the latest Windows 10 update (in this case ‘2021-08 update for Windows 10 vers. 21H1 : KB4023057’)

Update: This was only a temporary success: after the Windows update I was able to start the MSFS and install the WU6 Update including all scenery updates and executed a small circle in my vicinity and shutdown MSFS and my computer. This morning after reboot I am back at square 1 - the black screen of Doom. When I close MSFS, the desktop appears, but the flightsim process is not properly stopped (stilll visible in taSk manager). I have to logoff. When I start then again, I am prompted with a dialog: “MSFS not properly closed last time. Do you want to run in Safe mode or normal mode?” - also Safe mode just brings me to the black screen.
What an annoyence! Nothing is working, no proper error message!

When I opened a ZEN message I was advised of the following 3 topics discussing possible solutions to the “problems during start” issue:

  • try Fast launch
  • check sound output / use ‘spacial sound’
  • run game as Admin
  • unplug any USB device
  • uninstall/install MS Gaming service
  • apply all pending Windows update or any other MS Store update
  • sign off and sign in again into MS Store/XBox app
  • synchronize time settings
  • remove the community folder
  • disable the security and Antivirus software (not comment here from my side !)
  • disable certain non Microsoft programs

Actually, the advice to disable non MS apps helped me: I disabled all and the MSFS did start. I enabled all previous non MS apps one by one and tried the flight sim - MSFS started all the time.
In the end all disabled non MS app were enabled again and MSFS did start up. (I had the suspicion, that the August update of Adobe Lightroom and its cloud is the cause. But all is running now.)
I am slightly confused about this procedure.
I will check again tomorrow again and see if something changes.

To me only work this:

Change the sound output to your monitor or Turn on Spatial sound
This will be fixed in future? this post is from Jan.

1 Like

The same procedure for me after Quickfix-Update

  • MSFS starts and gets in a loop between 2 screens: “Please press any key” and “Welcome back to XBox” all over again.
    The same procedure:
  • disable all non-MS programms in Startup
  • enable XBox App as startup
    Start of MSFS works now
  • enable all non-MS programs inStartup again
  • disable XBox App in startup again (Annoying, that XBox market place opens up everytime, when I login)
    Result: MSFS is still starting correctly!

I am slightly disappointed of this repeated problems.

I am back to square one:
I have to permanently disable autostart of “GoogleDriveWS” to be able to run MSFS.
Otherwise I am displayed the “Press any key to continue” screen and end up in the black screen (loop).

The Black screen is taking took long to go away, almost 5 minutes. I am going to uninstall MSFS and reinstall it after SU 10. I assume I can make a copy of the community folder and just put it back in there afterwards. Starting when it is empty does not fix it

I keep on getting a black screen when mfs 2020 starts up on my paperspace cloud pc recently,it never used to happern :unamused:

Hi @IdleVessel38416 & welcome to the forums. :slightly_smiling_face:

This article may help you resolve this issue:
How to fix a black loading screen – Microsoft Flight Simulator Support (

Please let us know if the steps given in the article fixes your problem!

Moved to User Support Hub Install, Performance & Graphics that is more appropriate for community support.