Black Square planes - broken GPS, and Autopilot & workaround

While working with SPAD, building profiles for some Black Square planes, such as the Bonanza, Baron 58, I’ve noticed this weird problem.

When turning on the GNS 530, it seems to take much longer to acquire a GPS signal. Once it has, and you enter a GPS waypoint either as part of a flight plan, or a direct-to, the target doesn’t indicate a DTK, or distance. It also does not drive the HSI correctly.

Updated title to reflect it is not related to dev. mode, but a BKSQ issue, workaround to first spawn in a non-BKSQ plane first.

In addition to this, when using the AP, the various functions will activate, but it does not perform the action. It will not track a heading, GPS waypoint, or VOR. It will not level or obey a VS setting. All it does is level it’s wings, and tend to climb at a steady rate I have no control of.

Disabling dev. mode, quitting back to the main menu, and starting a new flight is not enough to fix this. The only thing that works is to completely shut the sim down, then re-launch the flight.

1 Like

Know issues ? – discussed recently on the WT Discord

1 Like

I just read that. Momo states that using “resync” or “build all” breaks it, but I did neither of those. I did press the reset flight button though, so maybe that triggered it. I’d need to retest.

I just found something semi-interesting. So I did the following:

Launched the sim, and enabled dev. mode.
Shut the sim down, and relaunched it.
Picked the Analogue Baron 58.
Entered LOWI - LOWS on the map screen, and spawned.
GPS is broken

So I don’t need to use any dev. mode controls to break it.

Returned to the map screen, disabled dev. mode.
Repeated step 4 above.
GPS is still broken.

I know that a restart of the sim will fix it so instead I tried this.

I switched planes to the Analogue Bonanza.
Repeated the LOWI-LOWS flight plan, and spawned
GPS now works.

Need to re-test this, but it kind of looks like switching planes is enough to fix it. Presumably I could then switch back to the plane I wanted for a given session, and not relaunch the sim. I also need to try switching planes on the map screen, and not spawning to see if that is enough.

1 Like

In my experience, and based on other reports, this isn’t specific to Dev Mode at all. There’s an issue with 530 and BS Analog planes since the SU14 update.

2 Likes

Yes, not dev. mode related, as I have come to find.

However I have found a repeatable workaround.

When you launch the sim, if you have it spawn the Asobo 172 Classic. Don’t even power it up, just immediately return to the main menu.
Now launch with the Black Square plane of your choice.

I’ve tried this multiple times now, and it works. I assume that other non-BKSQ 530 equipped planes will also work, but I have not tested those.

Wow, cool - will try that. I have no idea what that means in terms of the root cause, but hopefully somebody does (you?).

By “spawn”, I assume that means start a flight on a runway or gate or something. Not just select it in the hangar?

How on earth did you happen to figure that out?

1 Like

My brain moves in strange ways. :slight_smile:

Select the 172, the Classic 530 enabled one, not the G1000, spawn on the ramp, then return to the main menu. I assume spawning on the runway powered up would actually work too, though I never tested that.

Then pick the plane you actually want.

1 Like

Just had a short flight in the 207, which does not natively use WT technology…in 2023.

Anyway, when the flight ended, I re-spawned in the BKSQ Baron, entered a direct-to, and it worked! You can see details on the 530, and the HSI is showing deflection.

Hit the restart button, and the GPS is broken again, so that is consistent. Spawn one plane first, then switch to BKSQ. BKSQ to BKSQ equals failure.

Experienced the same problem yesterday. The GPS took 5 mins to find a signal. When it was ready and i took off, the autopilot did not react to anything. just flying straight.
This seems to be a very strange bug when you spawn a Blacksquare machine after another (or the same) Blacksquare machine.

Yep, exactly what I discussed in that thread. The workaround is to spawn in a non-BKSQ plane first. I have used the Asobo 172 Classic (not G1000). During testing I had fired up the avionics, then quit to the main menu, then spawned the Baron 58, but subsequent tests showed I didn’t even need to turn on the battery in the 172. Just spawning on the ramp, then quitting back to the main menu was enough to “fix” the Baron 58 GPS, and AP.

Thank you for this work around. It works for me.

1 Like

There is an actual interim fix, involved with copying in some replacement code.

1 Like

I too am having the same issues with the GNS530 and autopilot functionality in the BlackSquare Caravan. Looks like it is getting attention with JustFlight and Working Title. I tried the fix that has been mentioned/posted above and here are my results:

It did not seem to allow the GPS to sync with the Flight Plan created via the World Map.

The Vertical Speed function on the autopilot does not seem to work properly…it blows past the set Altitude instead of automatically reducing/adjusting the FPM to reach and hold the target altitude. I had to change the VS FPM to zero for it to hold level.

The Autopilot and the GPS appeared to be functioning properly in NAV mode (as was selected) but NAV was not illuminated/displayed on the AP unit so it was difficult for me to realize that until I watched the plane follow the flight plan accordingly. Instead, the autopilot just displays ROL mode even though it is functioning in NAV mode.

I flew an ILS approach and the AP was not very accurate with lateral navigation or maintaining the proper glideslope.

Once AP was disconnected, the ALT mode remained illuminated.

There are definitely some kinks that need to be worked out. Hopefully these issues can get resolved soon…this is the only plane I really enjoy flying.

Ticket that I posted on Just Flight. Is anybody else haveng this issue? “Dear Sirs.: I bought the three Airplanes the Black Square analog Beechcraft Bonanza, Baron and King from your site. I love the airplanes(I flew the Bonanza and Baron in real life, but I am now too old, so I fly them on the sim). But after the last MSFS Upgrade, the Garmin 430/530-autopilot are not working or do so erratically. I did look in as many places I could think for a fix, communities, google, etc and did not find a good answer, although some places got close to give one. I suspect you are overworked with lots of requests…which in one way is good?. May be you can help, so I can continue to enjoy your planes. Thanks. M.E V (msvirgili@aol.com)”

Yes, and a workaround was posted. It involves swapping out some code in one of the files.

The alternative is to spawn in a non-BKSQ plane, then quit back to the main menu, then spawn in the BKSQ plane of your choice. I think I posted about it somewhere in this thread…hang on.

Here we go:

I have that code in place, and it works well. I suspect that SU15 will undo this, or WT actually implement the suggested code change, and it won’t need to be tinkered with at all.