Blender 2.8 Glass texture for Airfield Clubhouse scenery

Hi i’m using Blender 2.83.5 and enjoying making scenery objects to replicate my local flying club, But I just can’t get the Window glass to work it all comes out opaque, even the predefined Glass in MFSToolkit, I have tried setting the Metallic to 1, also set the Transmission to 1, created the glass as a seporate object but it all comes out none usable.
Has anyone got any advise or can you share you material settings some how?.
Thanks in advance.


Under settings is the Blend Mode set to Alpha Blend? I’m just learning about this too so idk if thats the 100% correct way but if its all coming out opaque then thats one reason why it would.

In the Principalled BSDF shader, also set the Roughness to zero. This will make the glass clear.

Hi thanks for the reply Vipersnake94 and Taupe.
Taupe I have the roughness down to zero.
Vipersnake94: I missing the blend mode where you say it should be, but I’m sure I have seen this option but, I tried setting the Alpha _multiply in the nodes to zero but that did not help.
I will have a look at to find the Blend option again tomorrow and give you an update.
Thanks once again!.


Keep going further down, it’s just under texture maps. I’ve been using blend and that seems to be working. You have to really increase the Alpha in the image though to get the transparency. My glass is practically fully transparent but it turns out much more smokey.

EDIT: Then again, I haven’t played with the roughness like TaupeTerror3931 has said either so…

Thanks SnowboundSkink2 and everyone.
The Blend option didn’t show up as I was using the Cycles render engine, once in the Eevee renderer it was available.
Unfortunately it has not helped.
I will create a new scene and object from fresh and try that. I did try a new quick cube object and applied the MSFS glass material but could not get the package built for some reason so will try again later.
Thanks once again for your help.

Thanks everyone.
I was just about to throw in the towel when I lowered the Alpha multiplier the other way down, to 0.10 from 1 under the MFSF settings and that did it!. I was making changes in the Principled BSDF
which was not doing anything!. Phew what a pain that was!.
One thing I did find useful if you aren’t aware, whilst in the sim and the scenery editor with the object select in my case a window, I was able to make a change in Blender, export the glTF file and it updated live in Microsoft flight Simulator, before that I was closing down the sim, make a change then re-start the sim!.
Anyways thanks for all the replies and help!.
Pete.alpha setting

What are you using to control the level of transparency? It mentions using the Alpha channel, which would suggest the need to use a 32bit RGB format image although the docs say to use 16bit for everything. Is this the Alpha channel of the Blend map, diffuse map or something else?

I’m also struggling to get Roughness to do much in the sim. I have a roughness map that sets the Green channel to 0 and it looks great in Blender, but is dull as heck in the sim.

Many thanks.

I’m not using a texture.
I have selected MSFS Glass.
Looking at my settings there is a roughness scale under the MSFS settings in Material Properties but this is set to 1.00?.
I have shared my blender File maybe you can see what I have done for the glass to work. Let me know if this helps.


Thanks for this Pete. It helped, indirectly, but it helped for sure!

I’m rendering a few thousand coloured curtain wall glass panels. The gaps between them have different colour, depth and roughness. In blender I can achieve all of this with a diffuse, roughness and normal map, but FS2020 ignores at least one of those maps depending on the shader settings.

Anyway, I’ve mostly achieved what I need by just using the MSFS Glass shader, a base albedo colour and normal map. Just spent 2 hours trying to find out why the normal map works 1 time out of 100, but changing the shader from MSFS Glass and then back again mostly fixes this.

Now I just need to find out why the “Collision Material” option doesn’t seem to do anything. I can fly right through everything still)

Thanks again.

…and just as I say all is good… the diffuse colour has disappeared. I guess it wouldn’t be MSFS if things worked as you expected (or even logically…).

Hi FlightSimGuy!.
Glad it helped a bit!
Blimey your object sounds complex compared to my simple modelling ability.
It was certainly frustrating to get it to at work!.
Good luck mate!.


Hi thank a lot for this share , it helps me.

These are my settings, also using MSFS Glass

1 Like