Blender exporting

I’ve imported a large number of local landmarks in my hometown via the procedure using Google photogrammety data. Importing the extracted data into Blender and then exporting it to the modified SampleScenery folder, making all the necessary filename changes, etc., making sure textures winded up in the correct folder … it all worked like a charm.
So, I thought I’d create a few objects of my own in Blender. For some reason, the first one I did (a hangar at my local airport) worked fine, but then something I did must have changed.
I follow the same procedure to the letter, but the model doesn’t show up in the objects pane of the scenery editor.
Any idea what could be the block.
Textures are right size; I check all the appropriate boxes in the MSFS export pane in Blender; all files go where they should … but the models just won’t show up after I load the project.

I know it’s hard to analyze a problem by remote control, but I guess I’m wondering if anyone else has the problem.

Thanks in advance
John in Indiana


OK, it worked this time… although I don’t have a clue what I did differently.
Isn’t that the way it works, though? You hammer your head over a problem, then a minute after you post something on a forum … wham, you figure it out.

1 Like

Yes, Murhpy’s law of development. :smile:

Do this:

When you export the object in blender, open the dev mode, load the project and build it.

Then close the project, then load it again, and load the scenery part in the editor.

The object can be found by the SDK only when it is built into a BGL.

1 Like

Thanks for reply. Yeahj, I figured that part out, but I really think the problem was the model I built had some sort of error in it. I started again and built a simple model and got it into the sim. From there, I just increased the complexity, and had no problems. It can be so exasperating.

I have the same issue. Made a small lufthansa logo exported it correctly and the… nothing. I build some more models and exported them… nothing. I trouble shooted anything i could think of with an airport developer, nothing worked. The next day the lufthansa logo suddendly was in my objects menu, I have no idea why. Im waiting to see if the other objects will appear but I doubt it. Ive tried a ton of fixes, including all that project open build close stuff… nothing is wokring, I cant get objects into my project

Hi tigerfly, thanks for the tip! I was driving myself crazy trying to find the created objects in the library. I tried what you said and if finally worked.

1 Like