Blender import issues. No longer able to import certain aircraft

Just back from a week’s holiday and now unable to import most aircraft models into Blender. Was previously able to import the likes of Just Flight arrows but now I get errors on import and nothing is imported.
I have tried reinstalling Blender and the Bestdani import add on but still the same issue. Is anyone seeing this behaviour or any idea how to resolve? Not sure if a recent Blender update is to blame but I had not changed the import addon since Feb so not sure the cause.
Thanks in advance.

I’m currently experiencing this and getting the following error when I try import new models I had not imported before.
Python: Traceback (most recent call last):
File “C:\Users\35387\AppData\Roaming\Blender Foundation\Blender\2.93\scripts\addons\”, line 330, in execute
return import_msfs_gltf(context, self.filepath,
File “C:\Users\35387\AppData\Roaming\Blender Foundation\Blender\2.93\scripts\addons\”, line 305, in import_msfs_gltf
objects = create_objects(gltf[‘nodes’], meshes)
File “C:\Users\35387\AppData\Roaming\Blender Foundation\Blender\2.93\scripts\addons\”, line 235, in create_objects
trans = node[‘translation’]
KeyError: ‘translation’

location: :-1

I have updated Blender to the latest version 2.93.1 and re-installed the msfs importer add on.

Any help would really be appreciated.

Try the link in this post. Works for me…

That work for me…thanks for your help!!


I know this is an old post, but I have just got back into MSFS and wanted to create some livery for the aircraft flying out of the local airport. I have a few aircraft download and tried to open the model with blender. Now there are no gltf files in a lot of the models folder I have but the ones that do open give me the citation model. The plane that should have been there is the ATR 72-600.