Blender version, importer exporter for aircraft

Ok guys what have we all been using lately for importing and exporting our models? Especially exporting. I’m getting stuck with a bunch of importer/exporter errors. Tried

Just reinstalled Blender 2.92 due to some errors I was having on export, only for none of the MSFSToolkits or even the FBW toolkit working, throwing traceback errors. 2.93 did the same.

It’s what I was using previously with a fair bit of success (although still a hair-pulling exercise at the best of times).

Would I be better using 2.83? Or should I just give Blender up and source a #DS Max copy somewhere and figure that out?

MSFSTookit 0.40.0 AND the TML1024’s 0.41 fork both give install tracebacks when trying to activate them in preferences:

This was the exporter I was having the most success with before (although armatures were still not supported).
I tried placing them either in the ProgramFiles addons location, OR the users addons location, or just installing it from the .zip with the same result.

Whilst the FBW mod installs but gives traceback errors on export:

Blender 2.92 is a fresh install, with no other mods added other than default. Windows 10 fully updated.

If I can get it working, then this can Caravan Amphibian can get out there for us all!

This is my export process, but this is with the FBW exporter (usually used the MSFSToolkit 0.40.0 before these errors arrived)

I did see a dev from Asobo asking the FBW crew why they felt they needed their own exporter. So I’m hoping that’s a sign of better things coming ahead!

Any advice, or just your insight as to the importers and exporters you’re all using nowadays (NOV 2021) would be greatly appreciated, as everything seems over a year old now.

1 Like

I use 2.83 LTS with the 0.40 plugin and it works fine, but I don’t do anything too fancy with it.

They just said on the devsupport forum that an official Blender plugin is coming. It looks like they’re developing one of the existing ones.

1 Like


Using a fresh install of Blender 2.83.18 with the last plugin 0.41.4 (found on the TML’s github) give me satisfaction on SU7.
Warning, take a glance on your user directory ( …\Users"user"\AppData\Roaming\Blender Foundation\Blender) and removed all Blender directory corresponding to the version being installed ( 2.83 for exemple) in this place before installing Blender 2.83.X.
My Canso PBY and P-51 “Galloping Ghost” are compiled with this version and this plugin yesterday without any problem.

On the plugins side, we may have a nice surprise for Christmas 2021with what this post suggests: Provide an official Blender export plugin - MSFS DevSupport


Ok seems like Blender 2.83 is much more accessible then. I just successfully exported with 2.83 and 0.40, so I’ll give the new .41 a go.

Is MSFS building for you in sim? Or do you build using the external tool?

In sim brings up ‘Output path does not exist’ errors, even though it’s the one making them.

Since the first version in August 2020, I manage my project manually:

  • building a directory structure for my project,
  • creating a XML file to describe it,
  • to compile, just a drag and drop of this XML file on a shortcut (in the root directory of my project) pointing to the fspackagetool.exe of the last SDK releaded.

With SU7, I have used the DEV Mod in the simulator to correct the contact points but my compilation is always maded manually (old Linux user practices).

For CYMX and CTH3 buildings, I used the same practices.

1 Like

Indeed that IS exciting news!