Blinking clouds after patch 5

How is that even fair? I was working great with 780ti and now it’s absolutely unplayable unless I select clear skies… pathetic stuff from Asobo. Getting sick and tired of this game as the updates go on… lol

1 Like

Uhm…No! It was fine before put it back! I am not spending another dime on this. Can’t afford it, don’t need it, and you can’t make me! If you want to be like iPhone and cause unnecessary problems to make us upgrade, MSFS2020 is going to be a failure! Peace out!

Unfortunately it is what it is. For several days we’ve been gathering feedback from users with those GPUs and sending reports to Asobo, and this is their answer. While I don’t think there’s much hope left, you could still try and send a Zendesk report so they can properly realise the amount of users still using the affected GPUs.

I completely agree that is isn’t fair and that they didn’t handle this situation well at all, but unfortunately it doesn’t look like there’s anything we can do but upgrade. Be warned though, someone requested a refund due to this issue and was denied, so you’ll probably not have much luck if you do so too.

You’re right. The minimum requirements are a GTX770 at startup. This is declared invalid by Asobo overnight, so shortly after release. Such changes have to be made with the appropriate lead time. The players must have a chance to update their hardware for a longer time and even then there must be a fallback solution for a certain time (switch > to the old version without flicker). All other online games (Games as a Service) do the same, so that players are not excluded overnight. I do not agree with this approach by Asobo.

If you do not like Asobo’s approach towards this issue either, please do not neglect sending a Zendesk report and keeping the relevant discussion threads bumped. It is the only way to make them realise that this just isn’t the way to move forward, and that should this happen again, they must handle this better by providing earlier notice and explaining the exact changes in the patch notes. For this issue, we have had to troubleshoot and gather reports for nearly an entire week before official support let us know what is really going on.

1 Like

I already have, see:

I have raised this with their ZenDesk. Hopefully, they fix the issue because it’s clearly unfair when you meet the minimum requires or exceed them and still the game doesn’t work as it should?

Just about had enough of this… lol.

It is not only unfair to buyers with minimum requirements, but also completely unpredictable. Which processor or GPU generation is next in a short time? Everything down to i7 or Geforce 16xx?

Possibly, yes, as they tweak the graphics. Is it not unreasonable, as part of this 10 year lifecycle, that the product will change over time? That as improvements are made, hardware requirements may change. Let’s say DX13 comes along some day, and they move to that. The best you could hope of is that DX12 mode is even supported as some legacy mode, where some of the graphical improvements do not work.

We know that there will be a DirectX 12 update at some point along with the Xbox release, and it is understandable that after that some GPUs will stop functioning well (especially Kepler cards that handle DirectX 12 rather terribly). But this cloud issue came completely out of the blue, with absolutely no notice, and heck, the GTX 770 is still listed as the minimum requirement.

I’m still convinced that this is likely just a bug introduced with the cloud system improvements (which are not mentioned anywhere in the patch notes mind you) that would probably take more while than what they think is worth compared to the Kepler and Maxwell 1.0 userbase. Even so, they could have handled the situation a lot better and made a public announcement about this instead of sending the same canned response to support requests.

1 Like

I think one user already responded that support said it was a bug, but I would consider this as food for thought, and consider upgrades at some point. I think the writing is on the wall, as it were.

I think Microsoft/ASOBO were just being lazy to implement appropriate profiles for various hardware. For graphics settings they ought to set profiles so that the software detects that we have a 700 or 800 series GPU and as part of medium settings the render applies the correct handles to allow for the correct use of graphical features that is applicable to the detected hardware. It’s like people that have a GTX1080 cannot be expected to stop using flight simulator because their gfx cards do not have ray tracing…

Ultimately if GTA V and Read Dead Redemption 2 work fine on a 780m so should this buggy flight simulator especially that it worked fine form day one. The understanding from day one was that it’s a two way street the community has helped ASOBO to develop a successful products and ASOBO helps the community to enjoy the product. Any discontinued support for hardware needs to have appropriate notice or an offer of refund for those who bought the software which ultimately is no longer fit for purpose after 2 months from launch date.

2 Likes

MinimumSpec

Where did you find this? Microsoft Store and Zendesk continue to list the GTX 770 as the minimum, even though it says that the articles were updated just a few days ago…

Would be quite funny if they stated something as ambiguous as “GTX 700”, considering that all of the GeForce 700 series cards are affected by the cloud issue.

Go visit my youtube chan Buzzards on the Road. You might get inspired to make a video!

Hi,
my name is Max and this is my first post here - unfortunately because I got a serious problem with flickering clouds after the update today. When I change the weather to “clear sky” everything looks normal. The problem occurs with different aircraft and at different locations. Latest GPU driver is installed - changed nothing. I shot a short video to show you.

I hope someone can help fixing this.

Regards
Max

My hardware:
Asus B-450 M
Ryzen 5 3600
32 GB DDR4-3200
GTX 750 Ti :crazy_face: (gives me 20 fps with overclocking and low graphics - I’m waiting for the RTX3070/3060 :wink:)

Did you tried live weather?

1 Like

Yes. When it first occured I had Live-Weather on. Then found out it’s the clouds. When Live-Weather shows no clouds theres also no problem.

1 Like

Me too, Max!! I posted as well

1 Like

Yep, I’m getting this too. I have a 7 series GPU (770) so maybe it’s something to do with the low memory or just the age of the card. Video too large to upload to forum so here is YT link.