Boeing 747 Long Haul Crash To Desktop

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting.
Yes-Removed and tested
Are you using Developer Mode or made changes in it?
Brief description of the issue:
Boeing 747 causes sim to CTD about 1.0 to 1.5 hours after reaching cruise altitude
Provide Screenshot(s)/video(s) of the issue encountered:
Unable, sim totally shuts down
Detail steps to reproduce the issue encountered:
Take off with 747, obtain cruise altitude, sim crashes after 1 to 1.5 hours of flight
PC specs for those who want to assist (if not entered in your profile)
Intel i7-10700k @ 3.8 GHz
32 GB
RTX 3070
750 PSU
Did you submit this to Zendesk? If so, what is your ticket #?
have not submitted Zendesk, but have checked for similar posting and known issues

So I have tested 4 long haul flights with the 747. 2 of them were tried with the Salty Mod. All 4 ended up causing the Sim to CTD after reaching cruise altitude, about 1 to 1.5 hours after reaching cruise.

Things I have tried

  1. Removing other mods from community folder (try to keep minimal mods, FBW, CRJ working title and the Salty 747 only mods).

  2. 3 of the 4 flights have been the same long haul (KGRK to OKBK). Tried 1 on a different flight (EINN to OKBK).

  3. Did not use Salty mod for 2 of the flights with all other mods removed.

I have searched this forum, checked with Zendesk and glanced at the known issues. I was able to complete the achievement long haul with flying the 747 from Asobo base city to Seattle, but that was on my older less powerful PC (GTC 970, 5930k). This only happens with the 747. Able to complete long hauls with the 787 and A320 (including FBW) without sim crashing. I run 1440 on Ultra High with a few sliders down to 150 for perfect performance.

Is there still bugs with the 747? I know there was in the beginning, but not being able to complete a long haul with it had me stumped on the problem.

Thanks in advance for the help.

I have the same kind of issue since the latest World update 4.
The sim crasht, however this was after adding fuel the to center tank because of lack of fuel for the long haul trip from Schiphol to Willemstad with the 748.

After adding the fuel everything was fine, but as soon as I touched the FMC the sim crasht to the desktop.

Nvidia 3080
AMD 3700
during VR → Quest 2

Not sure if the center tank filled was my issue. I had it 100% full of fuel on departure due to the flight almost being as far as the 747 can go. After reaching cruise, would set the autopilot and touch nothing. About an hour later, the sim freezes and then desktop appears about 10 seconds later. Noticed the slight freeze on the last attempt.


Last night I installed update (cleaned the community folder for this), then loaded a 6000+ long haul flight. Used the 747 and had no issues. No CTD throughout the flight.

After I reached cruise altitude, I remembered to see if my settings have been changed from the update and they were. The settings got changed (sorry, cannot upload the photos at the moment). I plan to change them back to Ultra with terrain level of detail and objects level of detail set to 150 with 3 mods loaded (settings when the 747 would CTD). Will post an update to see if the sim update is what fixed the problem after another long haul test flight. Uploading: 20210414_125615[1706].jpg…

Your issue most likely comes from this: FPS Drop during flight - #6 by Goldsnape1
There seems to be a memory leak that causes long flights to slow down the sim until it runs out of ram and crashes.
The higher the graphics the sooner it crashes.

That does seem to fit what happens. Thanks for digging for that. will see if lowering some settings might fix it on my next long haul.

1 Like