Bredok 737 issues

I think this is an MSFS issue but can’t post there as this is an add on.
My ILS approaches fail every time, I should add that I have been flying ILS approaches using the iFly 737 in FSX so the issue is not with the way I am setting up the flight plan (well I don’t think so anyway)
I have tried using default MSFS flight plans and also using Simbrief and uploading to the FMC.
The issue is that the aircraft either does not recognise the ILS approach at all and therefore I get no Localiser and glide slope appear on the MFD or if it does then the aircraft autopilot starts doing strange manouvers when I’m within 15 or so miles resulting in steep dives into the ground at low speeds. I have tried taking manual control and have rescued the situation at times but I have now tried a number of airport approaches and the ILS fails at the final stages.
Ive tried the usual, removing and re installing the 737 and also removed all the add on content from my community folder with no change at all to the issue.
Its becoming a real pain to be honest so any advice would be appreciated but don’t tell me to uninstall MSFS and do a fresh install as that aint happening :slight_smile: ??

It sounds like an issue with this, lets say “not so great” AddOn that it doesnt capture the ILS…
You should contact the developer you paid the money for and not blame MSFS for “not so good” development work of a 3rd party plane. ILS in MSFS definitely works, as proved by other 3rd party planes and the default planes.


Thanks, I considered that may well be an issue but I have watched youtube videos of other users who do not seem to have an issue. Unless they posted those vlogs before the latest VI update?

I don’t understand why Microsoft let Bredok sells in the marketplace



I recently bought this model and have been able to do numerous successful ILS approaches. Hard telling what the differences are.


This airplane is notorious for being ■■■■… (not the plane itself, but this iteration of it in the sim). Don’t buy this until a real developer makes the 737

1 Like

Too late for me as I did purchase it.

Strange you have success and I do not?

Still can’t believe this thing was allowed on the Marketplace, I always look at reviews before buying but I guess it might suit some people.

Agreed but that doesn’t help solve my problem :+1:

I have more ILS problems with Aerosoft CRJ than the bredok 737, but I’m still on the previous version 1.25 after hearing about issues with the latest release. I don’t think those issues were related to ILS.

You can see if 1.25 version works for you.

Thanks, exactly how do you revert to the older version?

Remove the bredok folder from Community folder, and replace it with bredok folder from previous version.

If you don’t have access to the previous version reach out to developer