Britten Norman BN2 Islander cold start and nothing happens

I have been attempting a cold dark start for this aircraft. a pre flight checks have been done. after selecting the engine start switch nothing happens. I’ve even tried CTRL E and no rotation. What gives

Have you ticked all the items on the in cockpit checklist? If you look to your right, in the pocket next to the right hand seat, there’s a checklist you need to tick off.

1 Like

Almost certainly the intake covers left on, or whatever they are called.

I never primed the engines. It started after that.


I unticked all or CTRL E and for me nothing happen. I bought it today
Something change since one year?

Finally I found solution we have to put external power…

Was your battery flat? I haven’t flown this for a while, but I don’t remember ever having to use external power.

I dont know if my battery was flat but my plane had just been loaded from the simulator. Finally in this video at 5:00 the AvAngel had this problem to start both engines and found the solution by starting the APU

1 Like

Makes sense, and clearly I forgotten how that worked. The switch itself is clearly labelled.


1 Like