[BUG LOGGED] CTD caused by Capture One 20 codec

,

Unfortunately I did not help prevent ctds in my case, which are 99% of the time caused bei clr.dll… I have hoped so much…

Thank you, thank you very much! This trick solved my ctds!

only one codecs pack i use is k-lite mega, and what i know about dll, some time they are injecting by itself in the all specific program, same hook politic have much scripted files from tons of soft, like admuncher, or glassbrick, last i think create trouble, i notice some time when i disable it, no crash or less of them, i think in that case msfs guys have to rebuild their kernel for prevent injecting anything out of certificate for msfs, like fsuip or whatever msfs addons use, today we got billion software what can become problem in the games from lite as magnifiers to heavy like anti-virus/malware/whatever…

Ever since the mandatory update in August, I haven’t been able to complete the load up process without it CTD. as soon as I renamed that one file, it’s up and running/

Thank you

2 Likes

Excellent work @EmmaPeel7259 - Well done on spotting this!!

I had CTD issues since SU5 and ended up wiping my PC and only re-installing an OS and the necessary drivers and apps to get MSFS up and running. I did this the day before reading your post and, as I had Capture One 21 installed previously, it looks like you could have saved me a lot of work :slight_smile:

In my case I use both (CO and Logitech Multi Panel). And I’m having continuous CTDs.

You should not give up software that normally does not give any problems in Windows and that you use normally.
For example, Capture One, a widely used software among photographers, is not to be blamed.
Asobo must check this issue.

@EmmaPeel7259
Thanks a ton for your findings !!
I have CO 21, renamed the dll file … and now i can play (no more without CTD)

Regards.

So, this is interesting, it looks like NativeComWrapper is used for explorer integration. But possibly also for default file type opening. Someone needs to confirm this, but then we also need to know what file type mfs tries to open.

If for example the image type mfs is trying to open is a png and asks windows “give me the png file open handler” and it’s returning this dll, and this dll has an error, ctd’s can be inevitable if the source of that ctd occurs in that dll.

It looks like this dll is loaded by inherretance by another dll or returned to use so mfs loads this one, it is shown in the list because mfs is the main parent in either case. This is like (simplified):
MFS → yo windows, gimme codec → return registered codec dll.

As windows has an internal png handler, and if this has been replaced by CO, that could be a reason. With the dll renamed it will fall back to default.

So, there could be two reasons, or, the image has an error which the dll can not handle, or there is an error in the dll.

The above is assuming a default file handler has been updated by CO. Which is an obtrusive strategy in my opinion if no choice has been given to the user. Again, still an assumption.

Capture One 21 here, saw multiple DLLs from Capture One 21 loaded into the association with FlightSimulator.exe

First, I tried to remove Windows Explorer Integration from Capture One 21 to see if that fixed it without me renaming the DLLs. It did not.

So, I decided to uninstall Capture One 21 from my MSFS machine and left it on my second machine for the edits I need it for.

Am also downloading a fresh install of MSFS to give it my best shot and am going to fly sometime later tonight. If there are no CTDs then I will post my success story here as an update.

Excellent find OP if it works! Asobo should take note and see if they can blacklist the Capture One DLLs in an patch update.

Hello, I have found that in addition to the Capture One21 codecs, there are also the Nikon and Karspesky codes. I have put them in of, except those of Karpesky who tells me that I have to have permissions from the Systema.

I not own these CO, but so far I understood the discussion in CO forum, where an issue with these dll was already reported, the user have a choice to disable the explorer integration. May be disabling that, will also prevent that windows loads these dll as a default for somewhat.

1 Like

Disabling the explorer integration seems to help… Untill now MSFS is stable!

How to disable integration with the browser.

Found it somewhere in the general settings of capture one…

Oh man! I think u’ve made MY DAY !!!
Following yout instrutions, i’ve just been able to do 2 flights ina row (without quiting MSFS2020) with NO CTD !!!
Since SU5 i was not able to do any flight without ctd after 5-30 min…Until today!

THANK YOU !!! :+1: :+1:

Third test. Full flight. Full of addons, Madrid-Paris / Orly. 2 hours of flight, forcing cameras, views, etc. Perfect. I close the flight test. It works!!

This was definitely the reason for my nightmare since SU5. Thanks, EmmaPeel7259!!!

EmmaPeel7259,
Thanks a lot for your finding! All my CTD are now gone.
Now I can enjoy MSFS in all its beauty.
:+1: :+1:

After trying almost anything for weeks to get back the stability that I had before SU5, I came across this post and I have to thank @EmmaPeel7259 for noticing this problem and share it with us. After uninstalling Capture One (I almost never used it), I’m happy to say that after 2 tests in a route that was always crashing for me (LOWI-EDDS), I was able to complete both tests successfully!

Actually I received this afternoon a support ticket confirming that Capture One can prevent Microsoft Flight Simulator from running properly, it’s also nice to have an official response confirming that it can cause problems within MSFS.

Thank you again @EmmaPeel7259!

UNBELIVABLE! Renaming the “Capture One” P1.WIC.NativeComWrapper.dll" works flawlessly. Finaly I could fly my first CTD free ILS approach in EDDK again. Since SU5 all my approaches crashed to desktop. Also GA flying in Rio was totaly crash free. I thank you 1000 times for this post. :+1: :+1: :+1:

Wow!
I have Capture One 12 (too cheap to upgrade ;)), and renamed this .dll. I just tried a flight plan that always lead to CTDs before, and this time no CTD! Granted, I’ve had a lot of times where I changed something and thought I had fixed my CTDs only to CTD again on the next flight. But this seems promising!

So, for now: Thanks EmmaPeel7259!