[BUG LOGGED] CTD caused by Capture One 20 codec

CTDs can be caused by many reasons. This one is rather exotic and I like to share my findings for anyone with the same problem. I experienced many in-flight CTDs for weeks (or even months) and was not able to complete any flight for months.

Analyzing the windows error reporter logs I found a few suspicous dll files loaded into the MSFS process. These files belong to a codec installed by Capture One 20 and are not needed to run MSFS.

So, if you are experiencing similar issues and have a Capture One installation on the same machine, you can try the following workarround:

  • Go to your Capture One installation folder
  • Rename the file “Capture One 20\WIC\WIC64\P1.WIC.NativeComWrapper.dll” to “Capture One 20\WIC\WIC64\P1.WIC.NativeComWrapper.dll.off”

Warning: I do not know what for the codec is used in Capture One, so this may lead to other problems within Capture One.

I also opened a ticket in zendesk for this issue.

Mmmm… same CTDs problem (ALL CTDs started with WU5, no fixed with WU6), normaly in approach or final short with A320FBW, even with empty Community folder (only FBW developed, with defaul livery), and same DLL Capture One 20 in my PC.

I try to test this workarround this night or tomorrow. Thanks!!

Just had a CTD…minutes ago.
GPU at 50 degree and overall system is managing well, it’s the dam sim.
Il try your suggestion now.
Thank you

Very interesting! I also have Capture One and I’ll have to try this!

I’m assuming you have tested since renaming that codec and you’ve not had CTD?

Why would MSFS reach out and grab that codec? I dont understand that…very strange.

I can confirm that this solution is working out for me since I also have Capture One installed.

I was able to find some positions on the map, where MSFS always CTD! For example Ronald Reagan airport in Washington DC always crashed while loading. 90% of the time with a faulty module of ntdll.dll and the rest of the CTDs with the clr.dll. Those CTD only start to happen after WU5 and still with the new WU6

After renaming the P1.WIC.NativeComWrapper.dll file to something else I did not get any crashes there anymore. When I give it its original name back, MSFS crashes again at Ronald Reagan airport with the same error logs.

So that .dll file from Capture One was causing all that trouble for me with the typical 0xc0000005 code and ntdll.dll or clr.dll since WU5.

Excellent work from your side there, EmmaPeel7259. I will update my support ticket at Zendesk and Asoobo and tell them your solution.

2 Likes

Well … I don’t know … is this a mirage?

Since this morning I have tested the simulator on the same route, 360 degrees around Madrid, taking off and landing in Madrid / Barajas, using the same instrumental routes, the same runway. About 35 minutes of flight. I have been deactivating addons, and in the end I have ONLY been left with the FBW without third party liveries, and the Madrid / Barajas Airport made by Asobo. Real time and weather. AI traffic activated. Always, always, CTD at approximately 15 minutes. When trying to take an outside photo. In short end when deploying the landing gear

I have not managed to complete the flight in 14 last attempts.

I´ve ‘deactivated’ the DLL that our colleague EmmaPeel7259 comments and … this is the result:

Tomorrow I will continue doing tests, but at least tonight I will sleep with my TCPs in a hotel :laughing:, and not lying on the PC desktop looking silly.

We’ve been discussing similar CTD issues in another thread and Nvidia drivers came up. It sounds like 471.96 is known to cause instability and CTD issues in some games, and 471.41 seems more stable. What version are you running? Im just trying to figure out how many moving parts this fix has.

471.96 Version; date: Ago, 31, 2021.

FWIW, I have Capture One 21 build 14.3.0.
That DLL is there, but it isn’t loaded in my flightsimulator process.

Hi EmmaPeel,
I have Cone21 and will try your solution.
Hope it makes MSFS flyable again!
Will report back

Gert

The Nvidia drivers are stable. Atleast in my case they are not the reason for the CTDs with the error code 0xc0000005 in combination with either the ntdll.dll, clr.dll or ucrtbase.dll.

Currently I´m running 471.96 again since it does not make any different what driver I use.
I tested the version 471.68, 471.41, 471.11, 466.47, 466.11, 461.92 and 461.40 today. No CTD with the renamed Capture One .dll.

All without any driver related crashes like 0xc00000fd codes and some nv or nvmxxx.dll modules involved. Then they also would be random and I would not be able to reproduce them.

Further I can say the stuff like defective RAM, limiting your FPS, OC hardware, too less space on an SSD/pagefile , internet bandwith etc. are not the cause for those reproducable crashes with the the three .dll in my case. The following opinions are my observations and based on my test.

  1. Defective RAM
    Can be ruled out. You can test your RAM and if it does not show any errors its fine. When I installed a old broken 8GB memory module I get some random crashes with a total different error in the windows logs. Those CTD and errors in the logs cant be reproduced with broken memory.

2.FPS limitation
Does not makes a difference. Doesnt matter if I use low end or Ultra settings. Still crashes at the same spots.

3.OC hardware
If you massive do it, it will cause some graphic glichtes and some random crashes due to higher temperature but not with the .dll files. Also it crashes the whole system and not just MSFS. Downclocking the hardware like the GPU by 10-100 Mhz still crashes at the same spots.

  1. Too less space on the SSD/pagefile
    Tested it again with only 600 MB left on the same SSD as MSFS. Does not produce any of the .dll related crashes or any CTD at all. Also I barley get MSFS to use more then 12 GB of RAM in total. If you have over 16GB of RAM the pagefile should not fill up.

5.Bandwith limitation
Just increases the loading times of the scenery and does not create CTD. Limited to 5 Mbits or unlimited still crashes with the same .dll crashes. Rolling cache activated does not make a difference.

So far I would say those ntdll.dll, clr.dll or ucrtbase.dll CTDs in combination with the 0xc0000005 error code is completly on the software side and is not a hardware problem, driver problem or corrupted Windows installation.
Why MSFS loads that Capture One .dll file has not a valid reason in my eyes. Capture One was installed in March 2021 on my system and MSFS did not crash a single time. The crashes started with WU5 and the console release. MSFS seem to load some unrelated .dll files, cant handle it and then crashes since WU5.

The ball is at Asobo to solve the internal code problem.

I would recommend if someone has a CTD will flying in a certain area or starting/loading at an airport, they should check if the CTD always happend on that spot. If you can reproduce it, its some software conflict on your system.

4 Likes

I assume these capture one register itself for some codes, or whatsever and MSFS is simple a windows game :wink:

Heres as example a similar issue, where these tool let crash the explorer:

where a user mentioned the same solution as the OP mentioned:

Problem is solved!
You need to rename the file in the path C: \ Program Files \ Capture One \ Capture One 20 \ WIC \ WIC64
P1.WIC.NativeComWrapper.dll to the name P1.WIC.NativeComWrapper.old
Works! Explorer does not crash!

May be these explorer integration can be in meanwhile disabled within that tool, if these was the reason.

Second Flight with this FIX, compete Barcelona - Madrid.
I haven’t taken precautions. Top of addons, ULTRA config, like a Boss. And… completed without problems!!! :blush: This FIX work for me!!

OMG, I have Capture One 20 (and Capture One 21) installed on my machine as well.

Note that DLL is present both in Capture One 20 and 21, so I’m renaming both just to be safe.

Like a few others have mentioned, I began noticing a definite pattern to the CTDs, it would always occur during/just after takeoff at KOLM or within the vicinity of Yelm Wa (06WN). It doesn’t appear to be “random” at all like I first thought.

DLLs renamed. Will report back findings after extensive testing is complete.

How did you discover this DLL is being loaded by the MSFS processes? What tool did you use?

Renaming the DLLs resulted in my first successful flight in over 15 attempts.

You’re a genius.

seem to get CTDs every time I enter a glideslope at any airport but only with airliners. RNAV, ILS it doesn’t matter still CTD. I have C1 so I’m going to give this a try. Hopefully it works, will report back!

Just open the task mananger and then go to tap performance. In the left down corner there is the resource monitor. Open it and then switch to the CPU tab. Then all the open processes are listed. Start the MSFS and the FlightSimulator.exe shows up.

Click on the white box next to FlightSimulator.exe. You will see then an check mark. After that go to the Associated Modules tab at the bottom. There should be a orange wall with the text “filtert of FlightSimulator.exe”.
Then all the .dll files that MSFS has loaded will show up and their installation paths.

Should look the same as on the picture I posted above.

2 Likes

And Xbox series x and s

Hi EmmaPeel,
Thanks for this find. I ave capture one 21 and renamded the dll to .off
Tested with a problematic flight lo LIML, first with stock A320, then with FBW mod. Set active pause for one hour during cruise of flight, In both cases NO problem whatsoever on ILS, landing and taxi!!
I thank you very much. I will amend my ticket with asobo and give you all the credits for this find and solution.
You saved my flying online. Really great job!!!

with sincere thanks,
Gert

Further information:
After renaming the dll,
Capture one 21 is still functioning ok:
Tested import, export and edit photographs.

Gert

1 Like