Consistent Crash to Desktop [AMD GPU]

I recently returned to the game in December and updated it to SU7 after being absent since August. Since then, during every flight, the game will crash about an hour in. I have been in contact with support about this issue; I was told to look for solved threads with the error code 0xc0000005 and apply the fixes. So far, none of them have worked.

Are you on Steam or Microsoft Store version?

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting.

Are you using Developer Mode or made changes in it?
Yes, FPS Display

Brief description of the issue:
The game will crash on all flights longer than 30 minutes. When the game crashes, the audio cuts out, then the game stutters for a second, before closing without an error message. The crash has happened during all parts of the flight, but mostly on approach or after landing.

Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered:
Fly over 30 minutes
Game will eventually crash

PC specs and/or peripheral set up of relevant:
BIOS: F33a (type: UEFI)
AMD Ryzen 5 5600X 6-Core Processor (12 CPUs), ~3.7GHz
Memory: 16384MB RAM
Available OS Memory: 16328MB RAM
Page File: 33379MB used, 7524MB available
DirectX 12
AMD Radeon RX 6800

Logitech X56 Throttle and Stick
Thrustmaster TRP Rudder Pedals

Build Version # when you first started experiencing this issue:

Event Viewer screenshots:
Screenshot 2022-01-05 205457
Screenshot 2022-01-05 205517

Screenshot 2022-01-05 205606
Screenshot 2022-01-05 205639

Steps already tried

  • Following CTD articles on Zendesk
  • Turn settings down to minimum
  • Disable Live Weather and Live Traffic
  • Clearing Rolling Cache/increasing size
  • Reinstalling
  • Increasing size of pagefile
  • Verifying integrity of game cache
  • Safe mode
  • Going on other user
  • Cleaning community folder and all third party content
  • Updating Windows
  • Updating GPU Drivers
  • sfc /scannow
  • DISM.exe /Online /Cleanup-image /Restorehealth
  • Update All Microsoft Store Items
  • Install English (United States) Voice Pack
  • Synchronize Time Settings

How big did you make your page file?
16Gb works much better with a custom size in MSFS.
There are also a lot of posts in here with similar issues.
You may want to do a search for them, a lot of tips and advice there.
There are also some who are really having trouble trying to pinpoint the issue.
You look like you’ve covered most of the bases.

Another thing to try is your PC ports sleep setting.
When awakening from a low power mode, it will often crash the sim.

Do you have Capture1 installed?

So you are fully updated to SU8 now? ( I see there was another small file to update today also )

I have a similar spec system, the only difference is I use 32GB of ram, but still, running the sim on Medium should be a breeze on yours.

Are you running the Sim in DirectX 11 or 12 ? ( I am sure you would have tried this )

I still use DirectX 11 in the sim as I feel " don’t try a fix if it ain’t broken " and I haven’t experienced any CDT for a while now. ( and my PC is windows 10 64 DirectX12 ) All Players / Live Traffic / Custom Weather

1 Like

Excactly same issues here on a nVidia gpu.

A few minutes of flight and the audio cuts out dnd the game freezrs and ctd without any messages. Flightsim.exe every time.

Tried reinstalling, removing joystick etc. rolling back drivers, empty community folder etc.

Every other titles (also demanding) installed on my pc runs perfectly fine without any issues.

For the questions, the sim is fully updated. I set the pagefile size to 24GB, and I do not believe I have capture1 installed.
Thank you, and I hope this information is useful.

1 Like

This is very strange. It might sound off-topic if I say this has been happening on the Xbox Series X ever since SU7…but the Series X GPU is technically an AMD GPU. I’ve seen a couple of these CTD reports linked systems with AMD GPUs. I wonder if there is actually a link :thinking:

Try rolling back radeon driver to version 21. I’ve had ctd’s on version 22.

what’s up with capture one?

If you have it installed FS crash randomly every time you use it.
Search here how to fix this problem (you need to rename a dll in C1, of course C1 will work without problems)

=> [BUG LOGGED] CTD caused by Capture One 20 codec - #12 by MichaMMA

But the errors points for me more to gpu issue… May try to disable DX12 ( BETA!) setting and also set a max fps limit in ati-tool.

1 Like

I see you running your PC using DirectX12 but are you using DirectX 11 in the game or 12 ? because a few folks were having problems with 12.

I’ve tried both options in game; it doesn’t seem to make a difference.

Have you ever used the google map replacement mod?

My crash with my AMD is exactly the same every day many times.

I have not installed any map replacement mods