Incredibly frustrated with the constant CTDs

Many users get the false impression that they can workaround the obvious software defects of the simulator software. They can’t. Any attempt to fix these issues with workarounds is a waste of time.


Here is a place to download all the above packages.

You are in all probability going to have some of them already installed so when you come across one that is already installed just click repair and let the installer repair the installation. You will have to reboot your PC when finished and if any of the installers ask to reboot, do it! They are telling you to do so for a reason! Then when you log back into your PC after reboot just start back where you left off.

Also, be advised there might be some other software you have running on your PC that may need reinstalled after this. I’ll give you an example from my end. I have EVGA Precision, it’s an application that is used for controlling fan speed, lighting and overclocking for my GFX card, any time I mess with reinstalling these packages it breaks the app and needs to be reinstalled. Mind you, this is just one example out of too many to ever list here.

Also, I cannot stress to anyone enough that there are other applications and games, especially through steam games that come packaged with the game when it is installed. It’s a folder in the steam library directory called Common Redistributables And guess what? They are often older packages of .Net and subsequently can cause problems and the user isn’t aware of this, to them all they did was install a new game or an older game and then all of a sudden they go back to playing a game that was working fine before but then now it’s not.

Yes, and this can lead one to believe everything is fine, probably the worst thing anyone can do is conclude all is up to date because windows update says it is. Here is a snapshot of clr.dll on my machine. Presumably a more recent version than yours. There is no way currently that windows updates can check these dll files for version checks, and if they did they would end up causing more issues with other applications when replacing them, hence what I mentioned earlier.

DO NOT run the install_all.bat file included in the archive, convenient, yes, problematic, very possible.


Anyone having CTDs related to NVIDIA?
I had a few related to nvwgf2umx_cfg.dll and I was wondering if you have any suggestions in terms of what could be a possible workaround?

I have HAGS and Gamemode turned off now and I am also running the latest version of the drivers.
The windows 11 installation is brand new, 2 days old, because I tried to clean all up hoping that a fresh start would help me with the stability.

It didn’t :expressionless:

Should I run a DDU and rollback to an older driver? If yes, which version?


I too went to a dedicated sound card but because I would get audible crackling in the first five minutes of flight. Very happy with the SoundBlaster AE-5+

No. I am using driver 511.79. If that driver doesn’t help you then I suggest you create a new topic about your issue. It is not fair to the topic author to discuss it any more here.

Thanks, I will create a new topic.
I don’t want to be unfair to anyone…
@Salem978, sorry!

I would like repeat my question:

And more exact what you can do in case you have Capture-One installed:

I did all the steps. I’ve also disabled the associated problematic capture one DLL.
Let’s see if it works.

Still, this should be a top priority for MSFS team.

1 Like

In my case yes. Is that a known problem with the su9?

It was either .Net packages or the Capture One dll thing, but I’ve been flying for 2 hours without CTDs. That’s a first for me since the early alpha days.


No, it was a problem that occured pre- SU9
I’ll post the corresponding link here.
Constant CTD’s after Jan 2022 update - Bug Reports / CTDs - Microsoft Flight Simulator Forums
Solution see 39/144
It was solved by disabling ‘Sonic Studio Virtual Mixer’ in Win11\settings\system\sound\properties tab’
MichaMMA knows a lot of these things :wink:

1 Like

Just a heads up, this isn’t a .dll file that comes with capture one per se, it may come packaged with it but you don’t need to install capture one in order to have this specific dll on your system. It is a C++ component that Capture one is programed with. I have never installed capture one and this dll was installed onto my system from .Net packages. It is signed by Microsoft and retains Microsoft’s certificate, the digital signature. The thing is, and this is where often problems begin to occur, is that software developers often package the required components with their installers and these components are file versions that the program was developed on at the time of packaging. Software developers naturally do this in order to insure their programs work as intended. This increases the likelihood of updated dll files being overwritten by older ones.

It happens all the time. One can do a fresh install of their OS and even install all the needed .Net C++ packages and update them through Windows Update, and then turn around and install a year old game or year old program that hasn’t had their installers repackaged and tested on the latest component dll files.

It isn’t something that MS alone has control over. It’s just one little example of how easily the software environment can become pron to bugs.

1 Like

I was having a similar issue and it happened constantly. Come to find out, it was the sound setting. Go to General Options → Sound → Main Device Output Selection. Under Main Device Output Selection make sure DEFAULT is not selected and select the device actually being used for sound. It might be a long shot, but this stopped CTDs from constantly happening and have been CTD free for 2 days now.

Funny thing, that’s a tweak that goes back to like AirWarrior III (w/3D!)

I can confirm I’m CTD free now. Thanks everybody!

1 Like

Cool Beans

That’s great news. Well done community :slight_smile:

I say’d nothing against… I only know that in in the forum in 99.9% of the cases in which the users which report a clr.dll error , they have capture one installed and it is caused from that tool. Therefore is the windows event log entry so important within the users-error-report.
My “blind shoot” about the clr.dll at the beginning of the topic was the solution here for the OPs issue, so easy can it be :slight_smile:

Yeah. It could be that Capture One is registering the DLL somewhere and it’s in use all the time in a way that is incompatible with MSFS.
Among all the things I’ve tried to stop the CTDs (and succeeded), I’m positive that the solution was in disabling the .dll from the Capture One 11 folder.

1 Like

Since it seems like Asobo and MS is busy releasing fantasy content to the scenery viewer and incapable of fixing the Exception code: 0xc0000005 CTD’s, have we gotten any closer to finding out what the issue could be?

All my crashes have been the same type:

Faulting application name: FlightSimulator.exe, version:, time stamp: 0x00000000
Faulting module name: FlightSimulator.exe, version:, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x0000000001cbbc84
Faulting process id: 0xd04
Faulting application start time: 0x01d8706f1bf67ebe
Faulting application path: E:\Programs Games\SteamLibrary\steamapps\common\MicrosoftFlightSimulator\FlightSimulator.exe
Faulting module path: E:\Programs Games\SteamLibrary\steamapps\common\MicrosoftFlightSimulator\FlightSimulator.exe
Report Id: ef3f6282-0df7-4580-b0f4-e597ebe873b1
Faulting package full name:
Faulting package-relative application ID: