CTD because of CLR.dll, NTDLL.dll or KERNELBASE.dll file, since Sim Update 5

I’m sorry… I really thought it did, but after I restarted my PC it happened again! So i’m in the same boat… We’ll wait for the DEVs :frowning:

Well, there are things you can do. Reinstall as a last resort. Check everything is up to date, run in safe more, remove USB peripherals.

It’s worth checking the hardware. SU5+ does flog the hardware and any issues with things like overclocking might cause problems.

But basically, no, unless it’s reproducible there’s nothing much you can do about it. All the message really means is “it screwed up”.

One thing that might be worth a go, possibly, is running it in parallel with Process Monitor. I have tried this myself (my install worked, though I’m back on XPlane 11 because of other deficiencies) and it doesn’t seem to do much harm. It tracks system calls as you run programs, so it might possibly give a clue ?

Thank you, I have already tried everything you suggest. I actually re-installed Windows, so I would be sure no other programs and such conflicted with FS2020. So on a fresh Windows copy, with only FS2020 installed, and the latest drivers - it does not work.

@PaulRobson8096, i also already done complete new installations and updated to Windows 11. The CTD’s are still the same. So new installations are a big waste of time.

I had this issue with at least P3D v3.2 and v4.1 (I know, different sim, data, developer, etc.), but for me at that time what solved it were the drivers.
In case of P3D it was for me the use of the newest drivers. After stepping back to an older one (cost me days to find which one), I hadn’t had any Kernel related CTD’s. This could be a thing. (I’m just thinking out loud.) :sweat_smile:

Off course MSFS is different than P3D and any onther sim. I’m aware of that.

Thank you for sharing your experience!

  • To understand you correctly, you downgraded a driver, and then it worked? Can you remember which driver and for which program?

this should not be necessary.

How much RAM you own and how is the setting for your pagefile and how much free disc space you have ?

On other side the removal of pagefile can be a random result about the usage of your RAM. If this have some issues, it can also be caused by this. Thus try to disable xmp mode.

It does fix some things.

Problem is without diagnostics there is little you or I or anyone else can do.

I would suggest install X-Plane / FSX / P3D if you have them, or if not Flightgear.

Same here - get the NTDLL.dll crash after a few minutes of flying. Never had any (read: zero) crashes of MSFS2020 until SU5. After installing the update, I’ve had dozens and dozens. I’ve tried all of the CTD guide’s suggestions, also tried re-installing MSFS2020 from scratch. Tried a system restore. Also scanned my memory, SSD’s, and processor for errors.

Completely out of ideas.

And the suggestion that it is hardware related is actually a really bad thing, but not because of PC players having to track down mystery quirks with their machine. Its because lots of Xbox players are getting CTD’s like this as well. Do you think Microsoft wants to have to recall/repair potentially thousands of consoles? No way.

It’s in Asobo/Microsoft’s best interest to figure out what changed with SU5, and fix it. It may be the minority of people having issues, but its still a very significant number of people.

How do we better interface with Asobo? Because Zendesk is not understanding/helping at all.

1 Like

Hey my friend!

Do you have the Xbox and the Xbox Live app installed? If not, install them and see if this fixes the error.

I have just made another re-install of Windows and FS2020 and no crashes so far. I used to delete apps that I did not think I needed such as the two Xbox apps. But I think these are the problem. Since the Sim Update V, also was the launch on Xbox, there are a possibility, that they made some changes, so the Xbox apps are necessary to have installed.

Let me know your answer. :slight_smile:

MODERATOR EDIT:
Dear fellow Simmers
I share you problems, I have the same experience, after 2 to 3 min a CTD,everything updated, no improvement,
FS 2020 reinstalled, no improvement.
All this from SU5, there is no problem with the SIM for that.

Hopefully these problems will be solved, I can’t imagine that this did not come in the Beta version.

Beste mede Simmers
Ik deel u problemen, ik heb de zelfde ervaring, na 2 a 3 min een CTD,alles geupdate, geen verbetering,
FS 2020 opnieuw geinstalleerd, geen verbetering.
Dit alles vanaf SU5, daarvoor geen probleem met de sim.

Hopelijk worden deze problemen opgelost, ik kan mij niet voorstellen dat dit in de Beta versie niet navoren is gekomen.

@NIMUJOE , yes, i have the Xbox and Xbox Game Bar App installed. But i am not sure what you mean with Xbox Live App?

For me it were the Nvidea drivers. I can’t remember and find out anymore from which version I went back to…But we’re talking about early 2016 and late 2017. So, with P3D I tried to setup my PC back to a Windows version/‘configuration’ where my sim worked before. Then you know a bit more of the kernelbase.dll if it example causes the CTD’s via the sim, or that it can even be as simple as a Windows update…(had that once).

What I can advice you for MSFS is going back to an older driver from 2020 to early 2021. Other games/sims shouldn’t have an issue with this downgrade. From experience I know that kernelbase.dll errors can be very frustrating because it’s a too general error where it can be the software, Windows itself, a combination of that, etc…

Hopefully this is the fix for you, otherwise I hope that this puts you at least in a right direction.

Well I hate to be “that guy,” but for me it was the opposite. I used to not even be able to get the sim to load. Trying clean re installs of 466.xx driver did nothing to help. Upgrading to 471.96 and now i’ve not had those loading CTD. Now I get them in flight.

1 Like

I’ve just given up trying various solutions to identifying the cause of the clr.dll, ntdll.dll and kernelbase.dll CTDs that I’ve experienced since the release of SU5 and installed Windows 11 (without retaining any of my existing Programs or Settings). I did first try installing it over Windows 10 retaining programs but the crashes still occurred.

After completing the OS install, the Intel motherboard and NVidia drivers, I’ve only installed Steam, MSFS2020 (Steam Edition) and Orbx Central. The MSFS re-install was fairly painless as the content is on a separate drive and was found when I re-installed the executable that was downloaded via Steam.

So far after an hour flying before adding back all the WU content and the contents of my Community folder and a couple of hours since adding everything back in, all is well :slight_smile:

If you have Capture One software installed on your system, some great detective work has revealed that MSFS is loading Capture One DLLs which is causing the sim to CTD. Kudos to EmmaPeel7259 for this finding. Check out the thread here:

CTD caused by Capture One 20 codec - Bugs & Issues / CTDs - Microsoft Flight Simulator Forums

Thank you for this one! Could be why I had the crashes. I re-installed Windows, and have not installed Capture One yet. I see, I have to install that on another PC :slight_smile:

1 Like

@NIMUJOE, I have Capture One installed here and renaming the “P1.WIC.NativeComWrapper.dll” fixed my CTDs. :+1: :+1: :+1:

GREAT! Finally we found a solution that works! It’s good that we choosed to write on a topic instead of waiting for Zendesk haha :smiley:

Awesome to hear. Yes this community is a lifesaver. I’m sure many of the other solutions work for other issues/incompatibilities - there are likely many causes of CTDs with this sim.

1 Like