CTD because of CLR.dll, NTDLL.dll or KERNELBASE.dll file, since Sim Update 5

CTD on #pc Steam version, no addons/third party content, developer mode off.

Windows 10 v. 21H1 - Everything is updated, including Frameworks.

CTD’s since Sim Update 5. Before that, I never experienced a single CTD. Nothing was fixed for me, with World Update 6.

My CTD always happen after a couple of minutes in the air. When I’m just parked on the ground or sitting ready at the runway, the game runs fine, but when I take off and fly a couple of minutes, it happens.

After investigating my msinfo32 file, I saw that the game would crash because of a ntdll.dll file, sometimes because of a KERNELBASE.dll file, and also a clr.dll file.

I found out that the crash related to:
has the Exception code: 0xc0000005

It means that FS2020 is asking for access that it shouldn’t have. (0xc0000005 is the code for “access violation”)

The error 0xc0000005 is Access Violation error. When a program attempts to access memory which has been distributed to another process and is not available for this one, I’ll receive the error and the software will be terminated.

So it’s sounds like it has something to do with the Sim Update and that they did something to how the game runs.

I was guided by Zendesk several times since Sim Update 5, when it started, but nothings has worked yet.

This is a memory/RAM issue on your system only, which is why it’s not a common problem for others.

Try new and/or different RAM modules and make sure the Windows paging file is enabled.

Note: Since the contents of memory can be paged in/out of storage, it may also be worth looking into potential problems with your storage device(s).

1 Like

Sorry, since update number 5 I have exactly the same CTD problems and they appear even on a totaly new MSFS 2020 (MS Store) installation without any installed mods in the community folder. I already tried all the CTD tips of the Troubleshooting Guide and can say… none of them work for me.


|Vollständiger Paketname:|Microsoft.FlightSimulator_1.19.8.0_x64__8wekyb3d8bbwe|
|Zusatzinformation 1:|0bba|
|Zusatzinformation 2:|0bba58424861b60edf6a626e25369d93|
|Zusatzinformation 3:|9695|
|Zusatzinformation 4:|9695f5d2c1b40f1adccc28287769a158|


Problemereignisame: MoAppCrash
Vollständiger Paketname: Microsoft.FlightSimulator_1.19.8.0_x64__8wekyb3d8bbwe
Anwendungsname: praid:App
Anwendungszeitstempel: 00000000
Fehlermodulname: ntdll.dll
Fehlermodulversion: 10.0.22000.120
Fehlermodulzeitstempel: 50702a8c
Ausnahmecode: c0000005
Ausnahmeoffset: 00000000000357ae
Betriebsystemversion: 10.0.22000.
Gebietsschema-ID: 1031
Zusatzinformation 1: a824
Zusatzinformation 2: a8246ba26b9c8432b80fab90807e66d1
Zusatzinformation 3: 63c9
Zusatzinformation 4: 63c9b418d74b215e87ddd05d09e17a10


Problemereignisame: MoAppCrash
Vollständiger Paketname: Microsoft.FlightSimulator_1.19.8.0_x64__8wekyb3d8bbwe
Anwendungsname: praid:App
Anwendungszeitstempel: 00000000
Fehlermodulname: KERNELBASE.dll
Fehlermodulversion: 10.0.22000.132
Fehlermodulzeitstempel: d0701e22
Ausnahmecode: c0000005
Ausnahmeoffset: 000000000005a1b2
Betriebsystemversion: 10.0.22000.
Gebietsschema-ID: 1031
Zusatzinformation 1: 8330
Zusatzinformation 2: 83304c9321809f0263f1a16efeb04d59
Zusatzinformation 3: 0295
Zusatzinformation 4: 0295184e9e61db74583f8b3353dbad15

Thank you. That gives me a direction, to what I could be working with here.

Wierd that Zendesk never mentioned something like this.

I know. It is so frustrating, but maybe it is a problem with the RAM like [HethrMasn] mentioned. I will try to work with it, and maybe correct it in some way.

Hello again.

I just tried replacing my RAM, with RAM from my friends system, and the problem is still the same (crashes at the same time CLR.dll)

I made sure the RAM was compatible with my motherboard and also DDR4 and had the paging file enabled too.

So that concludes, that it is not likely a hardware RAM problem.

Do you know what to do, if it is a storage issue?

Again, FS2020 worked perfect before Sim Update 5, so there must be something in the software, that conflicts after the update… Everything else on the PC runs perfectly normal.

EDIT: My friend runs FS2020 perfectly fine with his RAM and system

What is the different between your and your friends PC? Different graphic card driver, windows updates, any USB devices etc.? I run Windows 11 already with all the latest drivers and sh*t but since Su 5 I get CTD’s without end. Even if I fly the Discovery Flight in RIO De Janero in OFFLINE mode. After a few seconds in cockpit view…boom…CTD. I also have the CTD problem if I’m close to my destination airports and wanna catch the ILS. BOOM…CTD. It totaly suuuuuuuuuuuuuuux!

We have almost the same hardware and we both tried playing the game with only mouse and keyboard attached. He also tried with my mouse and keyboard on his pc. Same version, updates etc.

It is so wierd! My CTD’s sound like yours too. A CTD after a couple of minutes in the air. I’m too is really frustrated…

I think I have finally solved the issue!!!

[HethrMasn] Pointed me in the right direction - the Windows paging file! (thank you)

I cleared the cache of the memory file and after that I have completed 2 whole flights!!

Clear it like this:

  1. Click the start menu and type Regedit. Click on the Regedit run command OR find the Registry Editor in other ways, like search.
  2. This will open the Registry Editor. Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management.
  3. Double-click on the ClearPageFileAtShutdown key on the right.
  4. Set the Value data field to 1 and click OK.

The next time you restart your computer, the page file will clear.

Source: https://helpdeskgeek.com/how-to/7-ways-to-clear-memory-and-boost-ram-on-windows/

EDIT: After another restart I got CTD’s again. I’m sorry. Thought I have fixed it… :frowning:

1 Like

There are a lot of C0000005 errors with MSFS. All it means is the system stack in your CPU is corrupt. This is usually due to duff programming - say storing a 5 character string in a space only big enough for 4 - the 5th overwrites something it shouldn’t.


@NIMUJOE , thank you for the tip. Unfortunately it didn’t help. I was just flying from EDDB to EDDH and got a CTD as always close to the destination airport Hamburg. I also tried the Discovery Flight in Rio and it booted me again. Guess I have to wait till the DEVs sorted their sh*t out.

Found someone saying the same thing while researching how to fix this issue, so I don’t know that there’s anything we can do to resolve this ourselves. Feels more and more like something Asobo and Microsoft have to sort out


I’m sorry… I really thought it did, but after I restarted my PC it happened again! So i’m in the same boat… We’ll wait for the DEVs :frowning:

Well, there are things you can do. Reinstall as a last resort. Check everything is up to date, run in safe more, remove USB peripherals.

It’s worth checking the hardware. SU5+ does flog the hardware and any issues with things like overclocking might cause problems.

But basically, no, unless it’s reproducible there’s nothing much you can do about it. All the message really means is “it screwed up”.

One thing that might be worth a go, possibly, is running it in parallel with Process Monitor. I have tried this myself (my install worked, though I’m back on XPlane 11 because of other deficiencies) and it doesn’t seem to do much harm. It tracks system calls as you run programs, so it might possibly give a clue ?

Thank you, I have already tried everything you suggest. I actually re-installed Windows, so I would be sure no other programs and such conflicted with FS2020. So on a fresh Windows copy, with only FS2020 installed, and the latest drivers - it does not work.

@PaulRobson8096, i also already done complete new installations and updated to Windows 11. The CTD’s are still the same. So new installations are a big waste of time.

I had this issue with at least P3D v3.2 and v4.1 (I know, different sim, data, developer, etc.), but for me at that time what solved it were the drivers.
In case of P3D it was for me the use of the newest drivers. After stepping back to an older one (cost me days to find which one), I hadn’t had any Kernel related CTD’s. This could be a thing. (I’m just thinking out loud.) :sweat_smile:

Off course MSFS is different than P3D and any onther sim. I’m aware of that.

Thank you for sharing your experience!

  • To understand you correctly, you downgraded a driver, and then it worked? Can you remember which driver and for which program?

this should not be necessary.

How much RAM you own and how is the setting for your pagefile and how much free disc space you have ?

On other side the removal of pagefile can be a random result about the usage of your RAM. If this have some issues, it can also be caused by this. Thus try to disable xmp mode.

It does fix some things.

Problem is without diagnostics there is little you or I or anyone else can do.

I would suggest install X-Plane / FSX / P3D if you have them, or if not Flightgear.