[BUG LOGGED] My Way Achievement does not unlock

This was a World Update (aka WU) it is developed by a team that has nothing to do with the core functionality of the sim.

Lodge a complaint after a Simulator Update (aka SU), such as the SU8 we are meant to receive March 1. They are, theoretically, releasing a beta candidate of this version soon. If you get involved with the beta you may be able to find out if this has been addressed.

Someone on TA just said the Sim Update 8 preview auto popped the achievement. Ill try that when I get home.

1 Like

The beta’s out?

Hope this does finally get a fix soon.

I was experiencing some other serious issues with MSFS & my Xbox Series X. Ultimately I had to completely wipe MSFS entirely, redownload, & reinstall.

Otherwise, I’ve now attempted this “my way” achievement multiple times with a roughly half & half spread of attempts being made still including certain marketplace add-ons being installed & some subsequent attempts being made with a 100% clean install but it still just fails to trigger every time regardless. (Definitely fundamentally broken.)

During one attempt I was trundling around Ireland in a Diamond DA40NG racking up 300+ mile trips for the “Jack of all planes” achievement… The weather was absolutely glorious with barely a cloud insight, when after nearly 3 hours in flight & knowing
I needed several more hours for the “Hydroplaning” achievement to trigger, the Hydroplaning achievement just randomly triggered for absolutely no reason whatsoever. (I haven’t even flown through any weather in the previous day or two either.)

I’m well over 100 hours logged in a single profile but the 100 hours achievement hasn’t triggered. I’ve obviously used the autopilot extensively throughout 100 hours of flight, yet the autopilot achievement still remains completely stuck on 0% as well.

The entire Xbox achievement system is terribly, terribly flawed in MSFS. Worse still, Xbox can & do block patches for other games or titles etc. if the developer doesn’t actively address bugs where the achievement system is affected. Yet, when it’s a MS product of itself that’s the problem then the rules suddenly don’t seem to apply or they’re clearly ignored for months on end. Must be nice to be so incredibly superior that such overt double standards can remain so publicly visible.

1 Like

I can confirm: Achievement pop on loading screen.
Downloaded beta update.

1 Like

Sounds like great news. From now until March 1, I’ll be wondering if any of my past attempts were good enough, or if I’ll have to give it another go. Maybe I’ll run it a few more times in the interim just in case.

1 Like

Mine popped as the game was loading. It’s just an Achievement but it was surreal seeing it after literally dozens of attempts and posting, reporting, and flat out begging Asobo to fix it for months.

Completionist is still bugged for me. I have all three bush plane Achievements and all landing challenges but my pilot profile only counted 2/3 of the bush flights. Not sure which one didn’t register so I’m flying them again in hopes that it’s recognized by the sim.

Speaking of Pilot Profile, I noticed that the Achievements there synched with my Xbox Achievements: something that had not been the case before the download.

There is a new landing challenge but it did not count toward my Decathlon progress. I wonder if it’s because it’s not the official update.

Update 8 worked for me. popped at login and I only really tried the achievement twice before seeing it was glitched for everyone else.

I tried the landing challenge this morning on Xbox and it didn’t update Decathlon progress, tried it on PC just now and it has counted towards the Decathlon achievement, maybe try it again, and log a bug if it doesn’t update it on Xbox.

1 Like

Wow. Thanks for the head’s up. Sounds like another bug.

Please keep all discussions about the SU8 Beta in the SU8 Beta forum.

The #bugs-and-issues subcategories are for public release builds.

I made a bug topic on the beta forums for the console spotlight event not tracking. PC tracks fine. I’m glad this achievement is getting fixed though!

2 Likes

Got the my way achievement!
Installed the beta, disconnected the hotas one (or the game won’t start) started it up and immediately got the my way achievement. Now installing 19G updates. Can’t wait to try it out.

Good to see some people got this achievment recently. I see “Jack of all planes” comments saying mods and non standard liveries make this other achivement impossible ; it’s maybe the same with “My way”. I suggest you try it with an empty community folder. Good luck up there…

Most achievement hunters know about mods and liveries messing with achievements and this was not the case with “My Way”. It only unlocked for about 10 people in over 6 months. I never downloaded anything outside the world updates and I even waited on those until all challenges were done

1 Like

I added these to your list, without success atm:
No copilot assistance
Online connection
Live weather
Present time & date
Standard livery
No mods in community folder

It unlocked for me the moment I got into SU8. Don’t even bother trying to get it before SU8.

1 Like

Nice, right after updating to official SU8 today, I also got the achievement…during app startup as well.
Good luck to everyone, trying to get this achievement :+1: .
Now it seems to be realistic to succeed :wink:

1 Like

Had the same myself. Finally all the hours wasted trying has paid off. :partying_face::partying_face::fireworks:

1 Like

Issue fixed in version 1.23.12.0