[BUG LOGGED] No AA Anymore On Menus in VR?

,

From what I’ve seen it seems fine. Running on Xbox. No fix required - are you playing on Series S, by any chance? Enjoy all.

Check out the jagged shadows, they’re maxxed out, including using TAA and the leading edges of the wings look jagged. I run on PC.

This is from my Prepar3D simulator. This is happening on all 3 of my computer systems.

As far as I know this game uses Deferred Rendering, which means you cannot use MSAA. If you’re trying to inject it through the NVIDIA control panel, you won’t get very far…

What do you mean with “SSAA”? Are you trying to do SSAA by the NVIDIA control panel, or through the game settings (by increasing the render resolution)?

Same Here, and I confirm it’s quite a regression !
I don’t know if it has any significant impact on performance but please, give us at least the option to re-enable it for those who want !

(Ryzen 5 5600x + RTX 3090 + Quest2)

2 Likes

Yeah, I don’t know if it’s low res or no AA, but it’s really annoying!

Yes it’s awful and some fundamental questions need to be answered:

  • Was this picked up in beta testing?
  • if it was why has this serious issue been ignored?
  • at what lengths are Asobo going too in order to rectify this issue?
  • how long will we have to wait for this regression to be fixed?
  • who is in charge of quality control at Asobo? If no one they need to hire someone!
1 Like

They need to hire me :D…Iv voted for this by the way…Also trying to set ya fuel from the menu Bar now is a right pain

Can confirm here also.

@Urroundnext how do you vote for an issue?

Anti Aliasing is definitely broken! Menus are horrible, and it does effect the visual Quality while flying as well. The racing sim “Iracing” did the same thing in one of their builds about a year and a half ago. It took them months before they corrected that error.

VR headset, Reverb G2

1 Like

I saw this as well and thought I was crazy until I saw this thread on the Developer Update. Definitely something that needs a look, and hopefully before the big VR overhaul.

DCS has also done the same thing. It is now also a shimmer fest and the devs are crazy quiet about it. This is usually not a quick fix but here’s to hoping that Asobo has better skills or luck. I will take either.

It’s not just the menus, for me I also have definite new shimmering/aliasing on buildings and trees in the middle and far distance. Quest 2, native resolution and 100 render scale.

2 Likes

Clearly ther menus are very jaggedy and if this is caused by a lack of AA then please help us fix this.

1 Like

Same here, makes me forget about playing on vr again. Please fix

1 Like

Note that this is about menus/overlays.
I think we should have a separate bug for in-game AA and shimmering.

3 Likes

There is already a bug report concerning the lack of AA in the overlays and menus ( https://forums.flightsimulator.com/t/no-aa-anymore-on-menues-in-vr/ ). This is a separate issue, concerning in-game AA. On my setup (Fresh install of MSFS post hotfix, no add-ons, no dev mode, 5800X/32GB/RTX3080Ti), I tried with multiple different settings, in particular different render resolutions (low and high) and different Nvidia Control Panel settings (including the default settings), on two different headsets (Oculus Quest 2 via Oculus Link and via Virtual Desktop, as well as HP Reverb G2). Note that for all tests, I had reflections set to OFF, as reflections have their own issues in VR. AA was always set to TAA for these tests.

Starting with the same settings I had in SU4, I can see that thin (antennas, towers, etc.) or high contrast objects (shorelines, buildings) are much more jagged than they were in SU4, and the aliasing of these objects moves as point of view moves, causing visible shimmering on sharp borders. Sometimes thin objects can even end up being either a jagged, shimmering blob (ILS antennas), or even just transparent/not appearing.

While this happens in pretty much any scenario and lighting conditions, it is very visible in the Rio Landing Challenge, in particular:
When the Rio landing challenge starts

  • buildings in the sun are shimmering due to the antialiasing (to the left, close to us)
  • the bridge crossing the bay is a shimmering jagged mess especially in the sun
  • some of the shore line decks and peers are the same
  • The white bars at the top of the glass cockpit display (within the display) are jagged, shimmering as I move my head

When turning on final

  • to my left there is an orange-ish building (right in front of a peer) is a shimmering mess, I can infer it’s supposed to have lots of horizontal lines/window rows, but all I see are jagged lines shimmering diagonally, like moiré
  • the peninsula covered in trees front left of the runway is a jagged, shimmering mess until I get closer
  • The bridge to the left of the runway, crossing to the mainland is a jagged shimmering mess
  • The coastline beyond the airport and to the left is a very aliased line (not so shimmering)
  • The small oval shaped island on the left of the runway is very thing with perspective, and appears jagged and shimmering
  • The airport buildings to the right of the runway are a shimmering mess
  • The antenna array at the start of the runway is a jagged, shimmering mess
  • Ditto for the light poles to the right of the runway

Note that I spend several hours fiddling with settings (OpenXR render res, in-game render res and graphics settings, UserCfg, nvidia settings, etc.) and the issue is consistent. Also, some players report not seeing the issue at all, which could mean there is a workaround (but if there is, I haven’t been able to find it).

32 posts were merged into an existing topic: [BUG LOGGED] AA downgrade since SU5 (in-game, not menus/overlays)

Advice from the dev team came to keep the VR vs. non-VR AA issues separate. We have merged it back into the OP. If anyone had voted previously, please re-vote as the votes stuck here. I apologize! Thank you.

Just as a side note in my replies above, I do not use VR at all.

This has all been happening in 2D mode for me.

Hope we can get a fix soon.

Thanks!

1 Like